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What is Workflow Designer?

Workflow Designer provides administrators with the ability to graphically create queues and routes for their
workflow processes, create rules and scripts to help manage items as they move through queues, customize
workflow views, and more.

In Workflow Designer, you set queue-specific privileges that give users and groups the ability to add,
process, archive, delete, or remove workflow items.

What is a workflow view?

A workflow process view is a mechanism that displays workflow items according to the view definition that
you create for your users.

Workflow views are available at the process or queue level. You can create a view for each process in your
environment. In addition, you can define a single view for each queue in a process.

In Workflow Designer, you can configure workflow views that are preset to display only the columns your
users need to see or work with, including custom property columns. You can also predefine sort order and
grouping of items within the view. This feature saves time for users, who are no longer required to manually
adjust the columns, sorting, and grouping each time they display search results.

When you configure process and queue views, the following conditions apply to the search results grid:

« When both user defined process and queue views are present, the queue view is the view that displays.

« When there is a user defined process view, but there are no user defined queue views, the process view
is the view that displays.

« When neither a process nor a queue view is defined, a system view displays.

« Changes you make to views while in ImageNowEXxplorer revert to the defined process or queue view
when you end a client session. To save your changes, create a private filter.

You can also define document, folder, and task views in View Designer and folder content views in
Management Console.

What is a workflow process?

A workflow process is a series of queues, routes, tasks, and rules reflecting the review path a workflow item
must take in order to meet the sign off and approval requirements of your work group.

Queues and routes are the basic building blocks of a workflow process. Queues are connected by routes, and
you can apply rules, alarms, and actions to your process in order to meet more advanced requirements. Each
department in an organization can manage its own process.

There are three major types of workflow processes:



e Ad-hoc workflow Used by dynamic workgroups that run individual processes for each item, which
typically relies heavily on e-mail and the use of alerts.

e Transaction-based workflow This is atask-based workflow that usually involves lengthy and
complicated processes, such as loan or claims processing, that involves multiple document and folder
types and a high level of customization.

e Document-centric workflow Focus is onthe document as the unifying object in the workflow
process. Documents are associated with owners, applications, rules, and routes.

For example, an accounts payable process typically involves invoice processing. To review invoices
over a certain dollar amount requiring a higher level of approval, you can create your own process with

tasks and rules that capture this subset of invoices for special review.

Get started

Queue action icons

When a queue has one or more actions, you can identify which queues in the process diagram are associated
with these actions by the icons visible in the queue. The actions represented by these icons are described in

the following table.

Action Icon Icon Type Description

£ Enabled alarm The queue has at least one
enabled alarm.

e Inactive alarm The queue has one or more
inactive alarms. No enabled
alarms are associated with the
queue.

% Inbound action The queue has an inbound action.

g’ Within queue action The queue has a within queue

action.
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Outbound action

The queue has an outbound
action.

Bw
'

Inbound and outbound actions

The queue has an inbound action
and an outbound action.

Inbound and within queue actions

The queue has an inbound action
and an action within the queue.




Action Icon Icon Type Description

e Within queue and outbound The queue has an action within
actions the queue and an outbound
action.
Dg;}' All three action types The queue has one of each action

type. There is an outbound,
inbound, and a within action on
this queue.

Queue menu bar

You can open a specific pane in the Queue Properties dialog box for any queue in Workflow Designer. When
you right-click a queue, the following options are available.

Name Description

Actions Opens the Actions pane for this queue.

Alarms Opens the Alarms pane for this queue.

Appearance Opens the Appearance pane for this queue.

Applications Opens the Applications pane for this queue.

Forms Opens the Forms pane for this queue. This option is
available only when a Worksheets or Forms license
is installed on your system.

Properties Opens the Properties pane for this queue.

Queues Opens the Queues pane for this queue. This option
is available for super queues only.

Reasons Opens the Reasons pane for this queue.

Removal Opens the Removal pane for this queue.

Routes Opens the Routes pane for this queue.

Sub Queues Opens the Sub Queues pane for this pane. This
option is available for super queues only.




Name Description

Users Opens the Users pane for this queue. This option is
available only for work and super queues.

Convert to Sub Queue Converts this queue to a sub queue. This optionis
available for work queues only. At least one super
queue must exist in the process.

Convert to Work Queue Converts this queue to a work queue. This option is
available for system queues only.

Move to Process Moves this queue to another process. This option is
available for work, system, and super queues.

Change process diagram settings

You can change the settings for a process diagram to include gridlines, force queues and routes to snap to
gridlines, and more. To change process diagram settings, complete the following steps.

The options on the Grid toolbar can have unexpected results so you may want to test the effects on a small
process before trying it on a larger process as there is no undo feature in Workflow Designer.

1. On the Grid toolbar, perform one of the following actions.

« Toturn the display of the gridlines on or off for the process diagram, click the Toggle Grid;
button.

« Toforce queues and routes to line up with the process diagram gridlines, click the Snap to Grid 1
button.
« Todisable users from moving any objects, such as queues or routes, on the process diagram, click

the Toggle Grid Read Only: = button.

» To enable shadows for objects on the process diagram, click the Enable Shadows = button.

Customize workflow settings

Customize task pane buttons

You can customize the Task pane buttons by selecting the amount of buttons to display and which buttons to
display. To customize the Task pane buttons, complete the following steps.
Open the workflow process for which you want to customize Task pane buttons.
2. Toshow the Task pane, click View > Task Pane.
3. Onthe Task pane, complete one or both of the following actions.
« Toshow more or fewer task pane buttons, click the Configure buttons drop-down and then click



Show More Buttons or Show Fewer Buttons.

« Toadd orremove task pane buttons, click the Configure buttons drop-down, point to Add or
Remove Buttons, and then click Queues, Routes, or Actions.

Define sort order of a workflow view

You can preset the order of workflow item sorting as part of a view definition. To define the sort order of a
workflow view, complete the following steps.

1. InWorkflow Designer, double-click the workflow queue.

2. Inthe View Preview window, right-click the heading of the column on which you are sorting.
3. Click Sort Ascending or Sort Descending.

Turn workflow pane auto hide on

You can configure workflow panes to hide automatically when you are not using them. To turn workflow pane
auto hide on, complete the following steps.

1. Inthe Task pane, click the Auto Hide button.
2. Inthe Overview pane, click the Auto Hide button.
Result If the pin button shows the pin facing down, auto hide is off.

Next If the pane is docked, hold the mouse button over the pane tab on the left side of the workflow grid until
the pane is undocked.

Delete text or comments from a process

To delete text or comments from a workflow process, complete the following step.

1. InWorkflow Designer, in the process diagram, select the text or comments box that you want to
delete.

2. Press DELETE.

Enable a removal method

You can enable Perceptive Content to automatically archive, remove, or delete items from a workflow queue
after a specified amount of time. To enable a removal method, complete the following steps.

When you select the Archive or Remove from workflow method, the document or folder associated with the
item remains in the Perceptive Content system.

1. Double-click the queue.
2. Inthe Queue Properties dialog box, in the left pane, click Removal.
3. Intheright pane, under Select a removal method below, complete one of the following actions.



Situation Steps

To allow an item to stay in the queue indefinitely. « Select None.

To remove the item but retain the item history for | « Select Archive. Note that archiving may not
reporting purposes. occur when a Within Queue action is set for
the queue.

To remove the item and its history from workflow. | « Select Remove from workflow.

To delete the item, item history, and associated o Select Delete from system.
document from Perceptive Content.

4. Under Selected removal method will be applied for items older than, set the Days, Hours, or
Minutes that an item remains in this queue before it is archived, removed, or deleted.

Queues

Draw a container around queues

Containers let you highlight one or more queues to indicate a relationship or grouping between them. If you
have many queues in a process, this color-coding option makes it easier to identify parts of your process
quickly. To draw a container around queues, complete the following steps.

1. Onthe Grid toolbar, click Draw Container.

2. Click and drag around the queues to draw a container.

3. Optional. To change the default container background or border color, complete the following substeps.

1. Verify that the Box Properties pane is displayed. If it is not displayed, click View > Box
Properties.

2. Select the container you want to change.
3. Inthe Box Properties pane, under Box Color, select a Background or Border color.

Turn on queue shadow effect

To create a three-dimensional effect on each workflow object in a process diagram, complete the following
step.

¢ Onthe Grid toolbar, click the Enable Shadows button.



Workflow Agent performance tuning

You can tune Workflow Agent to accommodate environments of different sizes. For systems that have
complex workflow processes, we highly recommend that your system administrator optimizes workflow
performance and throughput. Workflow Agent provides various configuration settings that you can adjust to
improve performance.

Workflow Agent queue processing

Each Workflow Agent polls available queues for work after a set duration. Once the duration has elapsed,
queues are acquired by a running Workflow Agent and checked for any outstanding work items. If there are
work items that need processing, then Workflow Agent selects a subset of the work items to work on. The
number of work items selected are based on the average time it takes a work item to complete. This ensures
that longer running work items do not starve out work items for other queues. If an acquired queue does not
have any work that needs processing, then polling for the queue will not occur again until after the
empty.queue.delay.seconds setting has elapsed.

Worker tuning

The num.workers setting determines how many worker threads each Workflow Agent can use to
simultaneously process work items. This setting also governs the number of queues that an agent is able to
monitor for work items at one time. If a system has a large number of workflow queues, we recommend
increasing this setting based on available system resources. System administrators need to ensure that they
do not increase this value past the capabilities of the host system, otherwise they can introduce throttling
which greatly reduces throughput.

The num.workers setting determines how many worker threads each Workflow Agent can use to
simultaneously process work items. By default, this setting also governs the number of queues that an agent
is able to monitor for work items at one time. If a system has a large number of workflow queues, we
recommend increasing this setting based on available system resources. System administrators need to
ensure that they do not increase this value past the capabilities of the host system, otherwise they can
introduce throttling which greatly reduces throughput.

A reasonable initial value for num.workers is based on the number of cores of the host that the agent is
running on.

Themanual.lease.semantics.enabledandworkflow.leases.per.instance settings have
been introduced to decouple the lease limit from the num.workers setting. It is recommended that system
administrators enable this functionality to ensure that queues can be monitored in a timely fashion without
having to increase the num . workers past the recommended limits for the host.

Ifmanual.lease.semantics.enabledis TRUE, areasonable initial default value for
workflow.leases.per.instanceis numberof workflow queues / number of workflow
running instances. This will ensure that all workflow queue s will be monitored for work in a timely
fashion.

10



work.queue.type.work.items.minimumand work.queue. type.work.items.maximum can be
adjusted to ensure that the number of work items can be appropriately regulated. If you have a lot of long
running work, you can increase throughput by adjusting work . queue. type.work.items .minimumto
ensure that at least this number of work items is consistently pulled off for work. These work items will be
split across theminimum.work.item.batches to be able to control the degree of parallelism for these
work items, when the number of items pulled does not exceed the batch.work. items.maximum. If you
have queues with a lot of quick action items, the work . queue. type.work.items.maximum setting can
be adjusted to limit the number of items that are pulled for work at one time. The max degree of parallelization
for this queue s action type willbe work.queue.type.work.items.maximum /
batch.work.items.maximum. It is recommended for initial tuning that this not exceed the number of
configured worker threads and can be adjusted as necessary to meet throughput targets.

Puller tuning

The num.pul lers settings determines how many queues can simultaneously be polled for work by each
Workflow Agent If you have a large number of queues, you should increase this setting to ensure all queues
can be polled within the empty.queue.delay.seconds time period.

A reasonable initial value for num.pullersis 3.

The agent.sleep.duration.seconds setting should be updated to 1. This increases the rate at which
queues are checked for work.

Empty queue delay tuning

After worker tuning and puller tuning, it may be beneficial to increase the empty . queue.delay.seconds
setting based on the current limitations of the system. If you have a large number of action queues in the
system and your Workflow Agent State Next Run Time Spreads are not able to get near the
empty.queue.delay.seconds setting's value, increasing this value adjusts the targeted delay between
work items to better represent the capabilities of the system. You can also adjust this setting if a large number
of inactive queues exist in the system, increasing this value minimizes the number of times that an empty
queue needs to be polled for work.

Determining workflow health

Workflow Agent state next run time spread

You can monitorthe IN_WF_AGENT STATE table to check the health of a system. The relevant information
that can be derived is by looking at the NEXT RUN_TIME column of the records. If these records are
processed in a timely manner, the expectation is that the difference between the MAX (NEXT RUN TIME)
and MIN (MIN RUN TIME) record without a lease is nearthe empty.queue.delay.seconds time. The
following SQL statements can be used to derive the MAX and MIN records in the table.

-— Microsoft SQL Server and Oracle

select MIN(NEXT RUN TIME) from inuser.IN_WF_AGENT_STATE where AGENT LOCK is
null;
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select MAX(NEXT RUN TIME) from inuser.IN_WF_AGENT_STATE where AGENT_ LOCK is
null;

Once these values are retrieved, they can be subtracted to derive the standard time wait for a workflow queue
action to be processed.

The following statement can be used to show how many work action queues are eligible to be processed but
have not yet been. A high value indicates that the system is over saturated and needs to be tuned further by
adjusting the num.workers and num.pullers settings.

-— Microsoft SQL Server

select count (*) from inuser.IN WF AGENT STATE where AGENT LOCK is null and
NEXT RUN TIME < GETUTCDATE () ;

-- Oracle

select count (*) from inuser.IN WF AGENT STATE where AGENT LOCK is null and
NEXT_RUN_TIME < SYS_EXTRACT_UTC(CURRENT_TIMESTAMP);

Application plans

Enable application plan linking on a queue

Enabling application plan linking on a queue allows your application plan to assign location, folder, and
document property values to captured documents within the queue. To enable application plan linking on a
queue, complete the following steps.

1. Double-click the queue.

In the Queue Properties dialog box, in the left pane, click Applications.

In the right pane, click the Application Plans tab.

Select the Allow linking from this queue check box.

In the Available Plans list, select the application plan you want to link from, and then click Add.
Repeat this step for each application plan you want.

o kw b

Selecting this check box prevents overwriting the existing values in any of the document keys. This
includes replacing an existing value with no value. Without this selected, every key is updated, based
on the configuration of the application plan, even if a field is undefined in the application plan. An
undefined key will overwrite (null) a value stored from the capture profile.

Optional. Click the Key Attributes tab and select the Update only empty key values check box.

7. Optional. Modify the key attributes privileges if needed. Key attributes include Location, Name,
Field1, Field2, Field3, Field4, Field5, Type, and Document and Folder Custom Properties.

« Toenable an attribute setting, click the column in front of the attribute until the green icon appears.
« Todisable an attribute setting, click the column in front of the attribute until there is no green icon.
8. Click OK.



Enable application plan validation on a queue

Enabling application plan validation on a queue allows Perceptive Content to validate workflow items against
your application plan when they are routed forward or back in the workflow process. To enable application plan
validation on a queue, complete the following steps.

A WODN -

Double-click the queue.
In the Queue Properties dialog box, in the left pane, click Applications.
In the right pane, click the Application Plans tab.

Under Host Validation, select the Validate workflow items against application plan when routing
forward check box if you want the document key validated when workflow items are routed forward to
the next queue in the process.

Select the Validate workflow items against application plan when routing back check box if you
want the document key validated when workflow items are routed back to the queue they last came
from in the process.

In the Validation application plan list, select the application plan you want to use for validation.
Selecting this check box prevents overwriting the existing values in any of the document keys. This
includes replacing an existing value with no value. Without this selected, every key is updated, based
on the configuration of the application plan, even if a field is undefined in the application plan. An
undefined key will overwrite (null) a value stored from the capture profile.

Optional. Click the Key Attributes tab and modify the key attributes privileges if needed. Key attributes
include Location, Name, Field1, Field2, Field3, Field4, Field5, Type, and Document and Folder
Custom Properties.

« Toenable an attribute setting, click the column in front of the attribute until the green icon appears.

« Todisable an attribute setting, click the column in front of the attribute until there is no green icon.

Click OK.

Modify application plan key attributes

You can modify the application plan key attribute settings for a queue to make the fields modifiable, allow
them to remain blank, and to allow host entry validation. To modify application plan key attributes, complete
the following steps.

Prerequisite You must enable application plan linking or application plan validation on the queue for these
settings to take effect.

In Workflow Designer, double-click the queue.

In the Queue Properties dialog box, in the left pane, click Applications, and then in the right pane,
click the Key Attributes tab.

Optional. Select the Update only empty key values check box.

Selecting this check box prevents overwriting the existing values in any of the document keys. This
includes replacing an existing value with no value. Without this selected, every key is updated, based
on the configuration of the application plan, even if a field is undefined in the application plan. An
undefined key will overwrite (null) a value stored from the capture profile.
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4. Modify the key attributes privileges if needed. Key attributes include Location, Name, Field1, Field2,
Field3, Field4, Field5, Type, and Document and Folder Custom Properties.

« To enable an attribute setting, click the column in front of the attribute until J appears.
« Todisable an attribute setting, click the column in front of the attribute until there is no green icon.

Note: Modifying settings for the Locationattribute affects the Drawer and Path fields in the
Properties pane in ImageNowViewer. For example, with the appropriate privileges in place, enabling
the Modifiable setting allows the user to move a document from a drawer to a folder from the
Properties pane. After a user saves the path, the Path field replaces the Drawer field.

5. Click OK.

Work with processes

What is a workflow process?

A workflow process is a series of queues, routes, tasks, and rules reflecting the review path a workflow item
must take in order to meet the sign off and approval requirements of your work group.

Queues and routes are the basic building blocks of a workflow process. Queues are connected by routes, and

you can apply rules, alarms, and actions to your process in order to meet more advanced requirements. Each
department in an organization can manage its own process.

There are three major types of workflow processes:
e Ad-hoc workflow Used by dynamic workgroups that run individual processes for each item, which
typically relies heavily on e-mail and the use of alerts.

e« Transaction-based workflow This is atask-based workflow that usually involves lengthy and
complicated processes, such as loan or claims processing, that involves multiple document and folder
types and a high level of customization.

e Document-centric workflow Focus is onthe document as the unifying object in the workflow
process. Documents are associated with owners, applications, rules, and routes.

For example, an accounts payable process typically involves invoice processing. To review invoices
over a certain dollar amount requiring a higher level of approval, you can create your own process with
tasks and rules that capture this subset of invoices for special review.

Create a workflow process

A workflow process contains a series of tasks and rules reflecting the review path a workflow item must take

in order to meet the sign off and approval requirements of your work group. To create a workflow process,
complete the following steps.

1. InManagement Console, in the left pane, under Select Department, select a department from the
list.

2. Intheleft pane, click Workflow.



3. Intheright pane, on the Workflow tab, click New.

4. Inthe Add Process dialog box, type a name and an optional description.
The description appears in the ToolTip for the process.

5. Click OK.

Next Create queues, routes, and rules to define the components in your new workflow process in Workflow
Designer.

Create a process view

A workflow process view displays workflow items according to the view definition that you create for your
users at the process level in Workflow Designer. To create a workflow process view, complete the following
steps.

1. InWorkflow Designer, click File > Properties.

2. Inthe Process Properties dialog box, in the Name box, type a unique name.

3. Optional. In the Description box, type a short description.

4. Under Appearance, complete one or more of the following actions:

Situation Action
Set preferences for how columns and statistics 1. Click the Preview button.
display in the view 2. Inthe View Preview window, make any

needed adjustments, such as adding or
resizing columns.

3. Click OK.

Set maximum results that display in the view « Inthe Maximum results list, type or select
a number.

Set the view to automatically run « Select the Automatically run this view
check box.

Restore the default view, which removes your « Click the Restore Default View button.

changes

5. Click OK.

Rename a workflow process

To change the name of a workflow process, complete the following steps.

1. InManagement Console, in the left pane, under Select Department, select a department from the
list.

2. Intheleft pane, click Workflow.



3. Intheright pane, on the Workflow tab, select a process and then click Rename.
4. Enteranew name for your process.

Modify a workflow process

To modify a workflow process, complete the following steps.
Prerequisite All other users must close the process.
1. InManagement Console, in the left pane, under Select Department, select a department from the
list.
2. Intheleft pane, click Workflow.
3. Intheright pane, on the Workflow tab, select a process and then click Modify.
4. When you are finished modifying your workflow process, close Workflow Designer.

Delete a workflow process

To delete a workflow process and remove all workflow items in its associated queues from workflow,
complete the following steps.

Prerequisite All users must close the process before it can be deleted.
1. InManagement Console, in the left pane, under Select Department, select a department from the
list.
2. Intheleft pane, click Workflow.
3. Onthe Workflow tab, select a process and then click Delete.

4. Inthe Delete Process confirmation box, to remove items from the queues in this process and then
delete the process, select the Remove all items from workflow and then delete this process
check box and then click Yes.

Hide Workflow Designer components

When you work with a process, you can hide components such as comments, containers, and routes. To hide
Workflow Designer components, complete the following steps.

When you open a process, all components are selected and appear in Workflow Designer by default.

1. InWorkflow Designer, on the View menu, point to Components and complete one or more of the
following actions.
« Tohide all comments that appear in a process, clear the Comments check box.
« Tohide all containers that appear in a process, clear the Containers check box.

« Tohide routes, point to Routes and then clear the Auto, Conditional, Conditional Parallel, or
System check box. To hide all routes in the process, clear the All check box.

« Tohide all text that appears in the process, clear the Text check box.



Add text or comments to a process

You can add text or comments to a workflow process to provide supporting information relating to the
process. The Text option adds text to the process diagram, while the Comment option adds text with a
surrounding border. To add text or comments to a workflow process, complete the following steps.

1. On the Grid toolbar, perform one of the following actions.
« Click the Add Comment button.
« Click the Text button.
2. Click and drag a text box in the area you want to add text.
3. Perform one of the following actions.

« Toadd atext that is not a comment, double-click inside the box in order to begin typing.
« Toaddacomment, type your message.
4. Click outside of the text box to see your results.

Create a route between processes

A route can connect a workflow queue in one process to a workflow queue in a different process. To create a
route between workflow processes, complete the following steps.

1. InWorkflow Designer, complete the following substeps.

1.

O b WODN

7.

Double-click the queue from which you want to start the route.

In the Queue Properties dialog box, in the left pane, click Routes.

On the Routes Out tab, click Add.

Inthe Add Route Out dialog box, click the Destination tab.

In the Business Process list, click the process to which you want to create a route.
Under Available queues, select the queue you want to route to and click Add.
Repeat the previous substeps for each queue to which you want to create a route.

2. Click OK twice.

Use overview pane to locate queues

The workflow Overview pane helps you locate specific objects on process diagrams quickly. To use the
Overview pane to locate queues, complete the following steps.

1. Inthe Overview pane, use the scrollbars to locate the area of the process diagram you want to access.
2. Inthe pane, click that area to move to the corresponding area on the process diagram.

Print a workflow process

To print a copy of the workflow process as it appears on the process diagram, complete the following steps.

1. To print the workflow process, click File > Print.

2. Onthe Print dialog box, make any desired changes to the print properties and settings and then click

OK.



Zoom in or out of process diagram

To zoom in on or out of a process diagram, complete the following steps.

1. Onthe Grid toolbar, perform one of the following actions:
« Click the Zoom In button.
o Click the Zoom Out button.
2. Repeat the previous step to continue zooming in or out until you reach the desired zoom level.

Export a process drawing

From Workflow Designer, you can export workflow process drawings to bitmap files. To export a process
drawing, complete the following steps.
In Workflow Designer, click File > Export.
2. Inthe Save As dialog box, complete the following substeps.
1. Inthe Save in list, select the location to which to save the exported file.
2. Inthe File name list, type a file name.
3. Inthe Save as type list, verify that Bitmap is selected.
4. Click Save.
3. Close Workflow Designer.

Work with queues

What is a queue?

Queues are one of the basic building blocks of a workflow process.

A workflow process is comprised of queues and routes that move items through your business processes. A
workflow item is the base component for workflow and it references a specific document or folder in
Perceptive Content. It is routed from queue to queue until it reaches its destination. These queues are linked
by routes.

Automated system queues - An Automated system queue (ASQ) is a predefined queue that performs a
specific action. For example, a Content ASQ automatically submits items to Content Server. A Transfer ASQ
sends items in the queue to the Object Storage Manager set that you specify when creating the queue.

o Super queues - A Super queue redistributes workflow items to a collection of distinct queues that
perform the same workflow function. These sub queues reduce the number of alarms, routes, and rules
needed.

o System queues -A System queue performs an action that does not require user intervention. For
example, a queue that automatically prints documents or faxes. The action is usually performed with a
rule or script.

e Work queues -A Work queue is a queue that is assigned to one or more users who are performing the
same action upon the same workflow items within the queue.



e« Complete queue property - This queue property sets the queue as the final queue in a process.
Any work, system, or super queue is allowed to be a Complete queue.

e« Join queue property - This queue property rejoins workflow items that have been routed in parallel.
Any work, system or super queue is allowed to be a Join queue.

What is a super queue?

A super queue is a queue that redistributes workflow items to a distinct collection of sub queues that perform
the same workflow function.

Super queues reduce the management of alarms, routes, actions, and rules by centralizing the administration
of the queues contained within the super queue. The queues within a super queue are unique queues that
work in parallel to process documents for a specific business function. For example, AP approval is a specific
business function.

Super queues provide the following benefits:

« Shorter process setup times

« Significant reduction in the management overhead for queues, alarms and routes
« Sub queues are transparent to the workflow user

« Sub queue users are automatically assigned the necessary privileges

o Sub queues can be created manually or automatically

What is queue conversion?

The queue conversion tool allows you to easily redesign an existing workflow process.

You can use the queue conversion tool to convert a work queue to a sub queue or to convert a system queue
to a work queue within the same process. The work queue to sub queue conversion is used to simplify a
workflow process. You can convert multiple work queues that are performing the same function to sub queues
by adding them to a super queue. The system to work queue conversion provides additional flexibility for
changing a process. Use this conversion type when you want the ability to scan into a system queue.

As part of the conversion process, workflow items that exist in the work and system queues are transferred to
the new queue type. Additionally, after the conversion process completes, the work and system queues are
removed from the process and no longer appear in Workflow Designer.

Types of queue actions

Use queue actions when you want specific events to occur on workflow items. You can assign three types of
actions to queues: the inbound queue action, the within queue action, and the outbound queue action. The
following table describes these action types in more detail.



Inbound queue action

Inbound actions are applied as workflow items enter the queue. You can specify an interval of time to
wait before the inbound action occurs by selecting or entering a number in the Process after box and
designating the period, such as minutes or seconds in the Period box. You must enter a number larger
than zero in the Process after box. The workflow item does not display to users as being in this queue
until the inbound action is executed.

You can use iScript for inbound actions but not workflow rules.

If you have a case where one document key value is updated based on the value of another document
key. For example, if Field3 = X, set Field1to Y.

Within queue action

Within queue action are applied as workflow items remain in the queue for a specified interval of time.
Specify the interval unit in minutes, hours, or days in the Waiting Period section.

You can either use iScript or workflow routing rules.

To route a workflow item to different queues based on a condition or set of conditions, you can construct
a conditional routing rule for the routing queue that accomplishes this action.

Outbound queue action

Outbound actions apply as items leave the queue.
You can use iScript for outbound actions, but not for workflow rules.

If you need a stamp annotation added to each workflow item as it leaves the queue, you can write an
iScript to accomplish this action.

What are automated system queues?

Automated system queues (ASQs) are queues that perform a specific action on the items you route to them.

ASQs automate actions that previously required a custom iScript. The Content ASQ submits items to
Content Server the Transfer ASQ saves documents in an OSM set specified by the queue, and the Convert
Form ASQ converts supplemental and stand-alone forms from HTML to TIF.

ASQs appear in the Queues pane in Workflow Designer and require minimal configuration. To configure an
ASQ, you select the process and queue to which to send items when the automated action is complete. You
can route items to ASQs using all of the supported routing options, including sequential, sequential auto,
parallel, or parallel conditional routes. Depending on the action ASQ performs, you might require additional
product installation and licensing. For example, to submit items to a Content ASQ, you must install and
license Content Server. If you do not have a Content Server license, the Content ASQ does not appear in
Workflow Designer.



What are Connect ASQs?

The Connect automation system queue (ASQ) sends web service notifications to your business applications.

Suppose you are the AP Manager and want to reduce the time and cost associated with processing invoices.
To meet these requirements, you implement an Connect ASQ. As an invoice enters this queue, Perceptive
Content sends a web service notification to the business application URI (Uniform Resource Identifier). The
business application receives the data you configure, such as invoice header and GL distribution information,
and creates the necessary payables invoice transaction, payment batch, and associated GL distributions.
Your business application can route the item to the success or failure queue depending on the process results
using a route item message sent to Integration Server.

To use the Connect ASQ, you must configure the connect.uri setting in the inserverWorkflow.ini file, to define
the REST endpoint that is invoked for each item in the queue. If the connect.uri setting is not present, the
Connect ASQ queue displays but does not process any items. Additionally, to access Perceptive Content
from your business application, you must have an Integration Server license.

What are Convert Form ASQs?

A Convert Form ASQ is a queue that converts stand-alone and supplemental form types from HTML to TIF.

Converting a form to TIF gives you the ability to annotate or email that form. For example, suppose you are
the director of HR and your department uses a form to capture employee 401K benefit information. When an
employee requests a copy of this information, you can email him or her the TIF version of the form.

Workflow Designer's Convert Form ASQ functionality uses form sets to determine which forms to convert. To
define a set, you select a form and the presentation template for the TIF. You can define an unlimited number
of form sets for each Convert Form ASQ. If you route a form to a Convert Form queue and no form set for that
form exists, the conversion process does not occur and Perceptive Content routes the form to the Success
Action queue.

After the conversion process is complete, Perceptive Content appends the TIF to the original form. The form
type determines the page placement of the TIF.

Convert an Integration ASQ to a Connect ASQ

To send web service notifications from Perceptive Content you must use a Connect ASQ. You have the
option to convert Integration ASQs to Connect ASQs using the inUpgradeUtil convert-integration-
queues command. To run the inUpgradeUtil convert-integration-queues command complete the
following steps.

1. Onthe Perceptive Content Servercomplete one of the following actions.

o InWindows 32-bit, open a Command Prompt window and change to the [drive:] \inserver\bin
directory.

« InWindows 64-bit, open a Command Prompt window and change to the [drive:]\inserver\bin64
directory.

« InUnix, change to the $(IMAGENOWDIR)/bin directory.

Note: To view detailed information about a specific inUpgradeUtil command, at the prompt enter



inUpgradeUtil --cmd-help convert-integration-queues. For more information, see
the Run INUpgradeUtil commands topic of Manage Content help.

What are Integration ASQs?

Creation of new Integration ASQs has been deprecated for Perceptive Content 7.2.1 and future versions.
Existing Integration ASQs can be modified but new Integration ASQs cannot be created. To send web service
notifications from Perceptive Content you must use a Connect ASQ which supports the use of REST APIs
instead of SOAP. Existing Integration ASQs can be converted to Connect ASQs utilizing the
inUpgradeUtil convert-integration-queuescommand.

The Integration automation system queue (ASQ) sends web service notifications to your business
applications.

Suppose you are the AP Manager and want to reduce the time and cost associated with processing invoices.
To meet these requirements, you implement an Integration ASQ. As an invoice enters this queue, Perceptive
Content sends a web service notification to the business application URI (Uniform Resource Identifier) using
the Envoy service operation name you define. The business application receives the data you configure, such
as invoice header and GL distribution information, and creates the necessary payables invoice transaction,
payment batch, and associated GL distributions. After this process is complete, your business application
sends a success response using Message Agent, and Perceptive Content routes the invoice to the success
queue.

To use the Integration ASQ, you must have an Envoy license. If this license is not present, the Integration
ASQ queue displays but does not process any items. Additionally, to access Perceptive Content from your
business application, you must have a Message Agent license.

What are ASQ consumable operations?

ASQ consumable operations are remote service operations that can be consumed by an Integration ASQ.

Integration ASQs can consume any remote service operation that meets the following parameter
requirements:

« Must have no more than 128 characters.

o Mustinclude ITEM_ID, QUEUE_ID, QUEUE_NAME, FAILURE_QUEUE_ID, FAILURE_QUEUE_
NAME, SUCCESS_QUEUE_ID, and SUCCESS_QUEUE_NAME.

Using the URI you provide, Envoy service retrieves a list of all remote service operations associated with that
URI. All ASQ consumable operations are displayed in bold.

Integration ASQ parameter map variables

When you route an item to the Integration ASQ, you can use a parameter map to send properties associated
with that item to the web service endpoint. The Integration ASQ supports a predefined list of document, folder,
workflow item, and custom property variables.

Note: Creation of new Integration ASQs has been deprecated for Perceptive Content 7.2.1 and future



versions. Existing Integration ASQs can be modified but new Integration ASQs cannot be created. To send
web service notifications from Perceptive Content you must use a Connect ASQ which supports the use of
REST APIs instead of SOAP. Existing Integration ASQs can be converted to Connect ASQs utilizing the
inUpgradeUtil command.

Custom Property Variables

This table lists and describes custom property data types. You can map all custom property data types
except a composite property or an array of properties from an Integration ASQ.

Data Type Description

Date Represents a date value

Flag Represents a boolean value

List Represents a predefined list value
Number Represents a decimal number value
String Represents a text field value

User Represents a user name value

Document Variables

This table lists document variables and their descriptions.

Variable Name Description

Drawer Represents the Drawer value
Field1 Represents the Field1 value
Field2 Represents the Field2 value
Field3 Represents the Field3 value
Field4 Represents the Field4 value
Field5 Represents the Field5 value




Variable Name

Description

Type

Represents the document type

Name

Represents the document name

Creation Time

Represents the document creation time

Notes

Represents the notes associated with a document

Folder Variables

This table lists folder variables and their descriptions.

Variable Name

Description

Type

Represents the folder type

Name

Represents the folder name

Creation Time

Represents the folder creation time

Workflow Item Variables

This table lists workflow item variables and their descriptions.

Variable Name

Description

Workflow Item Type

Represents the item type: document or folder

Object ID Represents the document or folder ID

Added to Workflow Represents the time when a document or folder was
added to workflow

Queue Start Time Represents the time when an item was added to the

current queue

Routed From

Represents the queue from which the item was last
routed

Workflow By

Represents the name of the user who added or




Variable Name

Description

routed the item to the current queue

Priority

Represents the item priority: high, normal, or low

Form types and Convert Form ASQs

This table lists each type of form and describes the page placement for that form type after it is converted

from HTML to TIF using a Convert Form ASQ.

Form Type

Page Placement

Stand-alone form (no attachments)

Appends the TIF to the form as page 2.

Stand-alone form (with attachments)

Appends the TIF to the form as the last page.

Supplemental form

Appends the TIF to the form as the last page.

Manage users

Add a user to a queue

To add a user or group to a workflow queue and assign queue privileges, complete the following steps.

1.
2.
3.

6.

Promote user to queue lead

Double-click the queue.

In the Queue Properties dialog box, in the left pane, select Users and then click Add.
Perform one of the following actions.

« Onthe Users tab, under Available Users, select a user and then click Add.
« Onthe Groups tab, under Available Groups, select a group and then click Add.

Click OK.

user or group.
Click OK.

In the Queue Properties dialog box, click under the column for the privilege you want to assign to the

When you designate users as Queue Leads, you grant them all privileges for the queue and authorize them to
change the status of workflow items to "ldle." To promote a user to Queue Lead, complete the following
steps.

1.
2.

Double-click the queue.

In the Queue Properties dialog box, in the left pane, select Users.




3.
4.

Select the user or group and then click Promote.
Click OK.

Remove a user from a queue

To remove a user from a workflow queue, complete the following steps.

A ODN -

Double-click the queue you want.

In the Queue Properties dialog box, in the left pane, select Users.
Select the user or group and then click Remove.

Click OK.

Create queues

Create a work queue

A Work queue is a queue that is assigned to one or more users who are performing the same action upon the
same workflow items within the queue. To create a Work queue, complete the following steps.

This procedure outlines the minimal steps required to create a work queue.

1.

o kw b

7.
8.

In Workflow Designer, in the left pane, under Queues, select the Work queue and then drag it to the
right in your process diagram.

Double-click the queue to modify its properties.

In the Queue Properties dialog box, in the left pane, select Properties.
In the right pane, in the Name box, enter the name for your work queue.
If you want to define a Join queue, select the Join queue check box.

Note: A Join Queue is one that rejoins a workflow item that you route in parallel by creating two or
more copies (siblings) of the original item. When they arrive in the Join queue, the items are rejoined as
the one workflow item that existed prior to the split.

To define this queue as the last queue in the process, select the Complete queue check box.
As an item is routed into a Complete queue, its status is then changed to "completed.”

Click OK.

Repeat these steps for each work queue you want to use in your process.

Create a super queue

A Super queue redistributes workflow items to a collection of distinct queues that perform the same workflow

function. These sub queues reduce the number of alarms, routes, and rules needed.

1.

2.
3.

In Workflow Designer, in the left pane, under Queues, click Super and drag it to the right in your
process diagram.

Double-click the queue to modify its properties.
In the Super Queue Properties dialog box, in the left pane, click Properties.
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4. Intheright pane, in the Name box, enter the name for your super queue.
5. Inthe left pane, click Sub Queues.
6. Inthe right pane, click New.
7. Inthe New Sub Queues dialog box, complete one of the following actions.
Situation Action
Create manual queues 1. Onthe General tab, click Manual queue
creationand type a name in the Name box.

2. Onthe Users and Groups tab, click Add.

3. Inthe Select Users and Groups dialog box,
on the Users tab, select each user you want to
assign to this queue, click Add, and then click
OK.

4. Inthe Select Users and Groups dialog box,
on the Groups tab, select each group you want
to assign to this queue, click Add, and then
click OK.

Create automatic queues, which creates a 1. Onthe General tab, click Automatic queue
separate queue for each selected user and creation so that the queue is named for you by
group using their user or group name for the Workflow Designer.

subqueue name. 2. Onthe Users and Groups tab, click Add.

3. Inthe Select Users and Groups dialog box,
on the Users tab, select each user you want to
assign to this queue and click Add.

4. Inthe Select Users and Groups dialog box,
on the Groups tab, select each group you want
to assign to this queue, click Add, and click
OK.

8. Click OK.

Create a system queue

A System queue performs an action that does not require user intervention. For example, a System queue
may be a queue that automatically prints documents or faxes. The action is usually performed with a rule or
script. To create a system queue, complete the following steps.

This procedure outlines the minimal steps required to create the different queue types. For setting some of the
more advanced queue properties, refer to the topics in the Queue Properties section.

1. Inthe Workflow Designer window, in the left pane, under Queues, select the System queue and then
drag it to the right in your process diagram.

2. Double-click the queue to modify its properties.



In the Queue Properties dialog box, in the left pane, select Properties.
In the right pane, in the Name box, enter the name for your system queue.
In the left pane, click Actions.

In the right pane, on the Inbound, Within Queue, or Outbound tab, in the Action list, select the script
or rule you want to use.

Click OK.
Repeat these steps for each system queue you want to use in your process.
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Create a transfer queue

A Transfer queue is an Automated System Queue that sends items in the queue to the Object Storage
Manager (OSM) set that you specify when creating the queue. To create a Transfer queue, complete the
following steps.

Prerequisite Before performing this procedure, you must create two queues: one queue for successful
transfers to the OSM set and another queue for processing unsuccessful transfers.

1. InWorkflow Designer, in the left pane, under Queues, select the Transfer automated system queue
and then drag it to the right in your process diagram.

2. Double-click the queue to modify its properties.

3. Inthe Queue Properties dialog box, in the right pane, under Details, in the Name box, enter the name
of the queue.

4. Under Automated Action, complete the following substeps.

1. Todesignate the process and queue for items successfully processed in this queue, in the
Success Action list, select a process in the Process list and then select a queue in the Queue
list.

2. Todesignate the process and queue for items that are not successfully processed in this queue,
in the Failure Action list, select a process in the Process list and then select a queue in the
Queue list.

Note: The transfer queue references the OSM set by name. Ensure the target OSM set and the
original OSM set are named identically.

5. Inthe OSMlist, select the OSM set in which ImageNow Server saves the documents.

Create a Connect ASQ

A Connect automated system queue (ASQ) is a queue that sends web service notifications to any business
application. To create a Connect ASQ, complete the following steps.

Prerequisite Before performing this procedure, you must create two queues: one queue for successfully
processed items and another queue for processing unsuccessful items.

This procedure assumes there is a configured connect. uri setting in the inserverWorkflow.ini file that defines
the REST endpoint invoked for each item in the queue.

1. Inthe Workflow Designer window, in the left pane, under Queues, select Connect ASQ and drag it to
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the right in your process diagram.
2. Double-click the queue to modify its properties.

3. Inthe Queue Properties dialog box, in the right pane, under Details, in the Name box, enter the name
of the queue.

4. Under Automated Action, complete the following substeps.

1. Todesignate the process and destination queue for items successfully processed in this queue,
in the Success Action list, select a process in the Process list and select a queue in the Queue
list.

2. Todesignate the process and destination queue for items that are not successfully processed in
this queue, in the Failure Action list, select a process in the Process list and select a queue in
the Queue list.

3. To set the number of days that items remain in this queue after the business application receives
a successful call for those items, in the Route After (Days) box, type a number.

By default, Perceptive Content routes items to the failure queue after one day. If your business
application does not place a web service call for an item, that item remains in the Connect ASQ
for the number of days you specify in the Route After (Days) box.

Note: You cannot assign a sub queue as a success or failure action queue.
5. Click OK.

Create a Convert Form ASQ

A Convert Form queue is an Automated System Queue (ASQ) that converts stand-alone and supplemental
form types from HTML to TIFF. Converting a form to TIFF gives you the ability to annotate or email that form.
To create a Convert Form ASQ, complete the following steps.

Prerequisite Before performing this procedure, you must create two queues: one queue for successful
conversions and another queue for processing unsuccessful conversions.

1. InWorkflow Designer, in the left pane, under Queues, select the Convert Form automated system
queue (ASQ) and then drag it to the right in your process diagram.

2. Double-click the queue to modify its properties.

3. Inthe Queue Properties dialog box, under Details, in the Name box, enter the name of the queue.

4. Under Automated Action, complete the following substeps.

1. Todesignate the process and queue for items successfully processed in this queue, in the
Success Action list, select a process in the Process list and then select a queue in the Queue
list.

2. Todesignate the process and queue for items that are not successfully processed in this queue,
in the Failure Action list, select a process in the Process list and then select a queue in the
Queue list.

You cannot assign a sub queue as a success or failure action queue.
3. Tocreate aform set, under Select Form and Presentation, click Add.
4. Todesignate the form to convert, select a form in the Form list and then to designate the



presentation template for the TIFF, select a presentation in the Presentation list.

If a form does not have any associated presentations, that form does not appear in the Form list.
Only presentations assigned in the Components pane for a form appear in the Presentation list.
5. Optional. To create additional forms sets, click Form and Presentation and then in the right column,
click the Insert Form Set+ button. Repeat the previous substep to complete the form set.
6. Optional. To prevent a custom javascript from rendering during the conversion process, under
Conversion Options in the Execute Javascript list, select Disabled.

Disabling javascript on a form in this queue ensures that the server does not become unresponsive
while waiting for the javascript to load. However, disabling javascript may also cause the system to
convert the form without populating all of the appropriate data.

7. Click OK.
Modify queues

About copying queues

The copy queue functionality allows you to copy one or more queues within the same process.

You can copy work, system, super, and automated system queues. In addition to copying the queue, you can
copy all queue property components, such as actions, alarms, reasons, and users, or just the components
you need. The paste option you select determines the components you copy.

About moving queues

The move functionality in Workflow Designer allows you to move a queue from its current process to any
process in your system.

When you move a queue, Workflow Designer retains that queue's property components, such as alarms,
routes, and users. You can move automated system (ASQ), work, system, and super queues. Use the move
functionality when you want to reuse your existing queues.

For example, suppose you are the Accounts Payable (AP) director and your current AP process contains
work queues for both the AP and Accounts Receivable (AR) departments. You decide to create a separate
process for the AR department. Instead of recreating queues, routes, and queue properties for the new AR
process, you can simply move the AR department queues from the AP process to the AR process. Because
the move functionality preserves the users, routes, and alarms, the AR department can immediately begin to
use the new AR process.

Rename a queue

To rename a queue, complete the following steps.

Double-click the queue.

2. Inthe Queue Properties dialog box, in the Name field, select the existing text, and then type your new
gqueue name.

3. Click OK.
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Copy a queue

You can copy a queue and all related components except for in routes. To copy a queue, complete the
following steps.

1. Inthe Workflow Designer process diagram, select one or more queues to copy, right-click, and then
click Copy.

2. Move the pointer to an empty space in the process diagram, right-click, and then complete one of the
following actions.

Situation Steps

To copy all components to the new queue o Click Paste.

To select the components you want to copy to 1. Click Paste Special.

the new queue 2. Inthe Paste Special dialog box, under

Select a queue component, clear the
check boxes for the components you do not
want to copy.

3. Click OK.

The new queue appears in the process diagram. If you selected the Routes component in the previous
step, defined out routes also appear.

Delete a queue

To delete a workflow queue, complete the following steps.
1. Inthe process diagram, select the queue you want to delete and then press DELETE.

2. Inthe confirmation prompt, click Yes.

Modify a sub queue on a super queue

To modify a sub queue on a super queue, complete the following steps.

Double-click the super queue.
In the Super Queue Properties dialog box, in the left pane, click Sub Queues.
In the right pane, select the sub queue you want to modify and then click Modify.
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Modify the following settings as needed.

« Inthe Modify Sub Queue dialog box, on the General tab, type a new name for your sub queue in
the Name box.

« Onthe Users and Groups tab, select the users or groups you want to remove and then click
Remove.

« To add additional users or groups, click Add.
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« Inthe Select Users and Groups dialog box, on the Users tab, search for and select the additional
users you want to have access to this sub queue, click Add, and then click OK.

« Inthe Select Users and Groups dialog box, on the Groups tab, search for and select the
additional groups you want to have access to this sub queue, click Add, and then click OK.

5. Inthe Modify Sub Queue dialog box, click OK.

Move a queue in a process
To move a queue to a new location in the process diagram, complete the following step.

« Select the queue you want to move and drag it to a new location in the process diagram.

Move queues to another process

You can move work queues, system queues, and super queues between workflow processes. When you
move a queue, Workflow Designer also moves the in and out routes for that queue. To move a queue to
another process, complete the following steps.

1. Inthe Workflow Designer process diagram, right-click the queues you want to move, and then click
Move to Process.

2. Inthe Move Queue dialog box, in the Select a process list, select the process to which you want to
move the queue and then click OK.

Delete a sub queue from a super queue

To delete a sub queue from a super queue, complete the following steps.

1. Inthe Super Queue Properties dialog box, in the left pane, click Sub Queues.
2. Intheright pane, select the sub queue you want to delete and then click Delete.
3. Click OK.

Move or delete several workflow objects

You can move or delete workflow objects individually or simultaneously. To move or delete multiple workflow

objects simultaneously, complete the following steps.

1. Inthe workflow process diagram, complete one of the following actions.
« Toselect several items at once, press CTRL and click each queue and route.
« Drag a box around the items you want to select.
« Toselect all items in the process diagram, press CTRL + A.

2. Todelete the selected objects, press DELETE.

3. Inthe confirmation prompt, click Yes.

4. Tomove the selected objects, hold the pointer over one of the selected item until it becomes a cross-
hair, and then drag the items where you want them in the process diagram.
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Configure queues

Set a queue as a join queue

A Join queue rejoins a workflow item that you route in parallel by creating two or more copies (siblings) of the
original item. When the items arrive in the Join queue, they become one workflow item again. Any work,
system or super queue is allowed to be a Join queue. To set a queue as a Join queue, complete the following
steps.

Double-click the queue you want to designate as the join queue.
In the Queue Properties dialog box, in the left pane, select Properties.

In the right pane, select the Join queue check box.
Click OK.
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Set a queue as a complete queue

A complete queue is the last queue in a workflow process. When an item reaches this queue, it's status is
"Complete." Any work, system, or super queue is allowed to be a Complete queue. To set a queue as a
complete queue, complete the following steps.

Double-click the queue.

In the Queue Properties dialog box, in the left pane, click Properties.

In the right pane, click the Queue tab.

Select the Complete queue check box.

Click OK.
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Enable route back on a queue

Enabling the Route Back setting on a queue allows users to route a workflow item back to its previous queue.
To enable Route Back on a queue, complete the following steps.

Double-click the queue.

In the Queue Properties dialog box, in the left pane, select Properties.

In the right pane, select the Allow route back from this queue check box.

Click OK.
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Enable route recall on a queue

Enabling the Route Recall setting on a queue allows users to recall a workflow item after it is routed to another
queue. To enable Route Recall on a queue, complete the following steps.

1. Double-click the queue.

In the Queue Properties dialog box, in the left pane, select Properties.

In the right pane, select the Enable route recall check box.

In the Recall period box, type or select the number of seconds this feature is available.

Click OK.
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Enable route from anywhere on a queue

A Workflow Process manager may designate a work queue or system queue as a route from anywhere
destination for workflow items within the same process.

Designating a queue as a route from anywhere destination allows users with process privileges on any queue
in the process to route items from those queues to the designated queue. Users do not need the route
anywhere privilege to send items to that queue. To enable Route From Anywhere on a queue, complete the
following steps.

1. Double-click the queue.

2. Inthe Queue Properties dialog box, in the left pane, select Properties.

3. Intheright pane, select the Enable queue as route from anywhere destination check box.
4. Click OK.

Enable sub queue routing on a super queue

Within a super queue, you can allow workflow item routing to occur between sub queues. With this feature
enabled, a user clicks Route Forward and routes an item to another sub queue in the Peer Routes list. To
enable sub queue routing on a super queue, complete the following steps.

1. Double-click the super queue.
2. Inthe Super Queue Properties dialog box, in the left pane, verify that Properties is selected.

3. Intheright pane, on the Queue tab, under the Sub Queue Routing section, select the Allow routing
between sub queues check box.

4. Click OK.

Convert a work queue to a sub queue

The queue conversion tool allows you to easily redesign an existing workflow process by converting a work
queue to a sub queue. To convert a queue, complete the following steps.

Prerequisite This procedure requires a workflow process with at least one super queue.

1. Right-click the work queue you want to convert to a sub queue.
2. Point to Convert to Sub Queue and then select the super queue you want.

3. If there are more than ten super queues in this process and you do not see the super queue you want, in
the Convert to Sub Queue list, click More.

4. Inthe Convert to Sub Queue dialog box, in the super queue list, select the super queue you want and
then click OK.

In the confirmation dialog box, the following message appears:
A sub queue will be added to <super queue>. All process users will be
transferred to the new sub queue."

5. Verify that the correct super queue appears and then click Convert.
The work queue you converted no longer displays in Workflow Designer.
6. Open the super queue to which the work queue was converted.
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7. Inthe Queue Properties dialog box, in the left pane, click Queues and verify that the work queue is
listed as a sub queue.

8. Click OK to close the Queue Properties dialog box.

Convert a system queue to a work queue

The queue conversion tool allows you to easily redesign an existing workflow process by converting a system
queue to a work queue. To convert a queue, complete the following steps.

1. Right-click the system queue you want to convert to a work queue and then click Convert to Work
Queue.

In the confirmation dialog box, the following message appears:

Converting a system queue to a work gqueue may cause some of the actions
to fail. Please make sure the action will not interfere with user
interactions before you proceed.

2. Click Convert.
3. To confirm that the conversion was successful, double-click the queue you converted.

4. Inthe Queue Properties dialog box, in the left pane, verify that Properties is selected. In the right
pane, under the General section, verify that in the Type list, Work appears.

The Type list is unavailable and appears dimmed.
5. Inthe Queue Properties dialog box, select the options you want for this queue and click OK

Result Action pane options are not retained as part of the system to work queue conversion. Other queue
properties, including alarms, application plans, reasons, and removal options are converted. System queue
routes are retained when converted to a work queue. As part of the conversion process, workflow items that
exist in the system queue at the time of conversion are transferred to the work queue.

Associate a form with a workflow queue

When you associate a form with a queue, users can complete a form for a workflow item as part of the queue
processing. To associate a form with a workflow queue, complete the following steps.

Displaying a folder as a form replaces any forms previously attached to any workflow queue with the form you
select in this procedure.

1. InWorkflow Designer, select a queue and then press ENTER.

2. Inthe Queue Properties dialog box, in the left pane, click Forms.

3. You can perform the following associations.

« Toattach forms to this queue, click Add, in the Select Forms dialog box, select the forms you
want to add and then click OK.

« Toremove aform from this queue, select the form in the list and then click Remove.

« To change the default form associated with this queue, select the form in the list and click Set as
Default.

4. Repeat the previous steps for any additional queues.
5. When you are done associating forms, click OK.
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Search

Search for a queue in Workflow Designer

To quickly locate a queue in a process, you can search by queue name. The matching queue and its outbound
routes appear highlighted. To search for a queue, complete the following steps.

You cannot locate sub queues with this search.
1. InWorkflow Designer, on the Find toolbar, in the Find box, enter all or part of a queue name. As you

type, Workflow Designer brings the matching queue into focus in the process diagram.

2. Optional. When there is a name match for multiple queues, to move to the next queue in alphabetical
order, click the Next button. To return to any of the previous matching queues, click the Previous
button.

Alarms

What is a workflow alarm?

A workflow alarm can alert one or more users of a critical task that needs to be performed or that is now ready
to be performed in a queue.

You can add Email, Perceptive Content Icon, Message Center, and Audible alarms to a queue to alert users.
For example, you can send an email alarm to the AP manager if the document property value is set to Reject.
Another kind of alert could be created that would show the AP manager that an item was routed from Legal
Review to the current queue. Alarms are useful because they relieve the user from having repeated
inspections of the status of multiple queues to determine whether critical tasks have been performed within a
certain time frame.

Define conditions for a rule statement

To add conditions to a statement in a routing or alarm rule, complete the following steps.

In Workflow Designer, in the Actions pane, click Manage Actions.

Select a rule and click Modify.

In the Rules Editor dialog box, select the statement and click Modify.

In the Statement Editor, under Conditions, perform one or both of the following actions.
« To modify the existing condition, click the blue underlined text.

« Toadd a new condition, click the Add:"u:‘button.

5. Inthe Constrain by list, select the kind of constraint to set up the lists you need in the Type, Field, and
Operator boxes.
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In the Type list, verify that Normal is selected.
In the Field list, click the field for the comparison.
In the Operator list, select the operator to use in the comparison.

© 0 N O

In the Value box, enter or select a value to use with the operator when comparing against the field and



10.

click OK.
Optional. Repeat these steps for any additional condition rows.

Configure email notifications

To configure the SMTP server that Perceptive Content uses to send all system email notifications, complete
the following steps.

1.
2.
3.

On the ImageNow Server computer, navigate to [drive:]\inserver\etc.
Open the inserverNotification.ini file with a text editor.

Inthe [Email] section, complete the following substeps.

1. Type the server name or IP address in the smtp. server setting.
2. Type the port numberinthe smtp.server.port setting.

Save and close the inserverNotification.ini file.

[Email]
smtp.server=MailServer

smtp.server.port=25

Create an email alarm overview

An email alarm causes an email message to be sent to a person or group through an SMTP server. To create
an email alarm, complete the following steps.

NoarowDd-R
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1.
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Activate an email rule

To activate the rule you associated to an email alarm, complete the following steps.

kw2

In Workflow Designer, in the Actions pane, click Manage Actions.

Select a rule and click Modify.

In the Statement Editor dialog box, to create a statement for your rule, under Statements, click New
In the Rules Editor dialog box, click Active and then click OK.

To close the Rules Editor dialog box, click OK.

In the Alarm Settings dialog box, in the Alarm Rule list, select the alarm rule you just created and
then click OK.
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In the Select Alarms dialog box, select the alarm you just created, and then click Add.

In the Queue Properties dialog box, verify that your email alarm is in the list, with a Queue Status of
Enabled and an Alarm Status of Active.

If you do not see the Alarm Status column, click Columns. In the Columns dialog box, select the
Alarm Status check box, and then click OK.

In the Queue Properties dialog box, click OK.

Create a queue link overview

To create a workflow email alarm that includes a link to the queue that triggered the alarm, complete the
following procedures.
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1.
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Configure queue link settings

To configure Alarm Agent to send email notifications with workflow queue links, complete the following steps.

1.
2.

3.

On the ImageNow Server computer, navigate to the [drive:]\inserver\etc folder.

Open the inserverAlarm.ini file in a text editor, and inthe [Email] section, set the
queue.email.link settingto 0 toinclude an Perceptive Content link.

Example queue.email.link=0,,or

Perceptive Content applies this setting to all queue link email alarms.
Save and close the inserverAlarm.ini file.

Create a queue link email alarm

To create a queue link email alarm for items that meet the conditional statements that you previously defined,
complete the following steps.

1.
2.
3.

In the Statement Editor dialog box, under Actions, click Add > Send email.
In the Email Alarm dialog box, in the Alarm name box, type a name for the alarm.
Under Email Header, in the From field, type an address.
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4. Optional. Inthe To field, type an email address. Enter addresses in this field only when you want to
email a user who is not assigned to the queue, such as a Department Manager who is not a process
user.

5. Select the Email all users in the queue check box to email all queue users.
6. Optional. Type addresses in the Cc or Bec fields as necessary.

7. Under Email Message, in the Subject field, click Add to Subject and in the Insert list, select the
option you want, such as Queue Name, and then click OK.

8. Inthe Subjectfield, next to %Queue_Name%, type the text you want to appear.
9. Inthe Body field, click Add to Body and in the Insert list, select the option you want.

10. Under Email Interval, set the interval for the time period you want between alarms. For testing
purposes, set the interval to 4 or 5 minutes.

If you set the interval for <X> days, Perceptive Content does not send another email for 24 hours.

Create anicon alarm overview

You can create an alarm that changes the state of the Perceptive Content icon in the upper-left corner of the
Perceptive Content toolbar. When you set this alarm, the icon changes from static to flashing, in a color and
flashing frequency of your choice. To create an Perceptive Content icon alarm, complete the following
sequence of procedures.

1.

1.

1.

1.

1.

.
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Create a Message Center alarm

When an alarm is assigned to a Message Center action, the alarm presents a message on the Perceptive
Content toolbar when a predefined condition is met in a queue. To assign an existing alarm to a Message
Center action, complete the following steps.

Note Message Center, Icon, and Audible alarms are not activated for owners, managers, or users with the
Department Privileges > Manage > Workflow Processes privilege.

In Workflow Designer, double-click the queue.

In the Queue Properties dialog box, in the left pane, click Alarms.

In the right pane, click Modify.

In the Select Alarms dialog box, select an alarm and click Modify.

In the Alarm Settings dialog box, in the Alarm Rule list, select Edit Rules.

In the Rules dialog box, select a rule and click Modify.

In the Rules Editor dialog box, select a statement and click Modify.

In the Statement Editor dialog box, under Actions, click Add > Message Center.
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10.
11.
12.

13.
14.
15.

16.

In the Message Center Alarm dialog box, in the Alarm name box, type a name.
Click Add to Title.
In the Insert dialog box, click Queue Name > OK.

In the Message Center Alarmdialog box, in the Message Title box, after the $Queue Name%
statement, type a message such as Attention!

Click Add to Body.
In the Insert dialog box, click Queue Name > OK.

In the Message Center Alarm dialog box, in the Body box, type some text around the query logic so
the incoming Message Center contains a full sentence, suchas There is an Invoice in the %Queue_
Name% Queue.

Click OK until you retun to Workflow Designer.

Create an audible alarm overview

To create an audible alarm that plays when workflow queue conditions are met, complete the following
sequence of procedures.

Note Message Center, Icon, and Audible alarms are not activated for owners, managers, or users with the
Department Privileges > Manage > Workflow Processes privilege.
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Create an alarm rule

To create an alarm that notifies the user when certain workflow conditions are met, complete the following
steps.
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In Workflow Designer, in the Tasks pane, click Actions.
Click Manage Actions.

In the Action Settings dialog box, on the Rules tab, click New.
In the Rules Editor, in the Rules name box, type a name.

In the Rule type list, select Alarm rule.

Click OK until you retumn to Workflow Designer.
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Change an alarm rule for a queue alarm

To change the alarm rule for a queue alarm, complete the following steps.
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5.

Double-click the queue you want.
In the Queue Properties dialog box, in the left pane, select Alarms.
In the right pane, in the alarms list, select the alarm you want to replace, and then click Modify.

On the Alarm Settings dialog box, in the Alarm Rule list, select the alarm rule you want to use
instead.

Click OK.

Define an audible alarm action

To define an audible action for a statement in an alarm rule, complete the following steps.

Note Message Center, Icon, and Audible alarms are not activated for owners, managers, or users with the
Department Privileges > Manage > Workflow Processes privilege.
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6.

In Workflow Designer, in the Task pane, click Actions.

In the Action Settings dialog box, on the Rules tab, select the rule and click Modify.

In the Rules Editor dialog box, under Statements, select the statement and click Modify.
In the Statement Editor dialog box, under Actions, click Add > Play sound.

In the Audible Alarm dialog box, complete the following substeps.

1. Inthe Alarm name box, type an alarm name.

2. Under Sound Selection, select a predefined sound or browse to the WAV file location.
3. Optional. To preview the audible alarm sound, click Listen to it.
4

To set the time between each audible alarm, in the In minutes, time between play box, type a
number.

Click OK until you retum to Workflow Designer.

Define an icon alarm action

To define the icon behavior in a statement for an Perceptive Content icon alarm rule, complete the following

steps.
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In Workflow Designer, in the Tasks pane, click Actions.

In the Action Settings dialog box, on the Rules tab, select the alarm rule and click Modify.
In the Statement Editor, select the statement and click Modify.

Under Actions, click Add > Flash icon.

In the Icon Alarm dialog box, complete the following substeps.

1. Inthe Alarm name box, type a name for the alarm.

2. Under Set-up, select the color you want and then shift the Frequency slider to the frequency you
want.

3. Click OK.
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6. Click OK until you return to Workflow Designer.

Enable or disable an alarm on a queue

To enable or disable an alarm on a queue, complete the following steps.

Ok wbN-=

Open the process containing the queue for which you want to enable or disable an alarm.
Double-click the queue you want.

In the Queue Properties dialog box, in the left pane, select Alarms.

In the right pane, in the alarms list, select the alarm you want to enable or disable.
Complete one of the following actions.

« Toenable the alarm, click Enable.

« Todisable the alarm, click Disable.

Modify alarm settings

To modify alarm settings for an alarm assigned to a workflow queue, complete the following steps.

Note Message Center, Icon, and Audible alarms are not activated for owners, managers, or users with the

Department Privileges > Manage > Workflow Processes privilege.
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5.

In Workflow Designer, double-click the queue containing the alarm you want to modify.

In the Queue Properties dialog box, in the left pane, select Alarms.

In the right pane, in the alarms list, select the alarm you want to modify, and then click Modify.
In the Alarm Settings dialog box, modify the following settings as needed.

« Inthe Name field, type a new alarm name.

« Inthe Timeout Period field, adjust the timeout period for the alarm by typing or selecting a new
timeout period.

« Inthe Status field, change the alarm status by clicking Active or Inactive.

« Inthe Alarm Rule list, select the alarm rule you want to use instead. Select Edit Rules if you
want to create a new alarm rule to use with this alarm or edit the current alarm rule.

Click OK.

Remove an alarm from a queue

To remove an alarm from a queue, complete the following steps.

1.
2.
3.

Double-click the queue you want.
In the Queue Properties dialog box, in the left pane, select Alarms.
In the right pane, in the alarms list, select the alarm you want to remove and then click Remove.

42



Set alarm priority for a queue

Alarms for a queue are prioritized according to the order in which the alarms are created. To change the alarm
priority for a queue, complete the following steps.

1.
2.
3.

Double-click the queue.
In the Queue Properties dialog box, in the left pane, select Alarms.

In the right pane, in the alarms list, select an existing alarm and click either the Move Up or Move
Down button to change its priority.

Repeat the previous step for each alarm until all of the alarms are ordered in your preferred priority.
Alarms have priority from the top down in the alarms list.

Show or hide alarm columns

You can determine which alarm columns display globally for all queues in all processes. To show or hide
alarm columns, complete the following steps.
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5.

Double-click any queue.
In the Queue Properties dialog box, in the left pane, select Alarms.
Click the Columns button.

In the Columns dialog box, select the check boxes for the columns you want to display and clear any
check boxes for columns you want to hide.

Click OK.

Test an alarm

To test an email, icon, or audible alarm that you created in Workflow Designer, complete the following steps.

1.

On the Perceptive Content toolbar, click the Workflow arrow, point to your process, and then select
the queue where you added the alarm.

Verify that there are some workflow items in the queue that meet the conditions you defined in your rule,
and then complete one of the following actions.

Situation Steps

Test an email alarm 1. Check your email account. You should
receive an email with a Subject field of the
name you gave to the alarm and a body text
message such as the following: There are 5
email items in the email queue.

2. Select all the workflow items, right-click,
point to Workflow, and then click Route
Forward.

3. Inthe Route Forward dialog box, select a
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Situation

Steps

qgueue and then click Route. This clears the
alarm state for the queue.

Test an audible alarm

« Verify the sounds plays if the alarm
condition is true.

Test anicon alarm

« Verify the Perceptive Content icon flashes if
the alarm condition is true.

Routes

What is a route?

A route is one of the basic building blocks of a workflow process.

Routes connect workflow queues. They can be inbound or outbound or both. Routes connect queues

contained in the same process and between processes.

The type of route you define depends on how you need to process items between workflow queues. The
following table describes the route types available in Workflow Designer.

Type

Description

Conditional

A conditional route is a route that is determined by
rules that occur dynamically in the process. The next
queue in the process is determined by information
received by the workflow process. For example, in an
approval process where an invoice over $5,000 must
go to the Finance Director, the process automatically
routes invoices greater than that amount to the
Finance Director.

Inter-process

An inter-process route allows you to route items from
a queue in one workflow process to a queue in
another workflow process.

Load balance

A load balance route processes high volumes of
items, such as ten thousand or more items per day,
and allows you to route items using distribution. The
distribution option you select determines how
Perceptive Content routes your items. You can
choose to route using a high volume load-balancing
algorithm that distributes approximately the same




Type

Description

number of items among the destination queues. As
an example, when you define four destination
queues and there are 20,000 items, this distribution
option routes approximately 25 percent of items to
each queue. Alternatively, you can choose to route
items to the destination queue with the fewest
number of items. This option means that the faster a
user processes items, the more items he or she
receives.

Parallel

A parallel route allows multiple actions to take place
at the same time. Multiple processing of the same
document can occur and be brought together at a
specified queue. When all processes are completed,
the next action is initiated. With a parallel route, a
workflow item is routed to more than one queue at
the same time and when all actions on the item
(sibling) are complete, the sibling items are routed
forward and rejoined in a join queue. Iltems you route
into a queue in parallel cannot be routed to another
parallel route because they are already split.

Parallel conditional

A parallel conditional route is a route that allows
multiple actions to take place at the same time and
also allows you to place conditions on the route.

Peer A peer route allows you to route items between sub
queues within a super queue.
Sequential A sequential route is a clearly defined route with little

variation. One action must be completed before the
workflow item is routed to the next queue. Manual
routes are used when there is more than one queue
an item might be routed to next. Requires the user to
select the destination queue from the available
routes list.

Sequential auto

A sequential auto route is a clearly defined route
with no variation. One action must be completed
before the workflow item is routed to the next queue.
Automatic routes require no additional user
interaction after the Route button is clicked. There is
only one queue the item can route to next, so it is
automatically sent to that queue.




Create aroute

Routes connect workflow queues. They can be inbound or outbound or both. You can route workflow items to
a queue contained in the same process or to a queue in a different process. To create a route, complete the
following steps.

You can only create load balance, sequential, sequential auto, and parallel routes using the Task Pane. To
create conditional or parallel conditional routes, refer to those topics.
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5.

In Workflow Designer, in the Task pane, click Routes.

On the Grid toolbar, verify that the Normal Routes | button is selected.
In the Routes pane, select a route type.

Click on the queue where you want the route to begin and drag your cursor to the queue where you want
the route to end.

Repeat these steps to create all routes within your workflow process.

Create a parallel route overview

A parallel route allows multiple actions to take place at the same time on a single workflow item. In a parallel
route, a workflow item is routed to more than one queue at the same time and when all actions on the item are

complete, the sibling items are routed forward and rejoined in a join queue. To create a parallel route, complete

the following sequence of procedures.

Prerequisite Before completing this sequence of procedures, you must have at a workflow process with at

least four queues.
1. /1.
2. /1.
3. /.

Add an outbound parallel route

To add a route out of a queue that routes an item to multiple queues in parallel, complete the following steps.

A ON -

In Workflow Designer, double-click the queue.

In the Queue Properties dialog box, in the left pane, click Routes.
In the right pane, on the Routes Out tab, click Add.

In the Add Route Out dialog box, do the following substeps.

1. Onthe General tab, in the Name box, type a name for the route.
2. Inthe Type list, select Parallel.

3. Optional. To enable ad-hoc parallel routing from this queue, select the Enable ad-hoc parallel
routing check box.

If you select this option, when routing forward from this queue, the user can parallel route to one
or more of the queues selected in the Available queues list.

On the Destination tab, perform the following substeps.
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1. Inthe Business Process list, select a process.
2. Inthe Available queues list, select the queues for this parallel route and click Add.
3. Click OK.

6. Onthe Routes Outtab, in the route list, verify that the parallel route name and the queues you selected
appear.

7. Click OK until you return to Workflow Designer.

Remove a route

To remove a route from a queue, complete the following steps.

1. Double-click the queue you want to link to another process.
2. Inthe Queue Properties dialog box, click Routes.
3. Onthe Routes Out tab, select a route, and then click Remove.

Note: You cannot remove conditional or parallel routes from the Route In tab.
4. Click OK.

Delete aroute
To delete a route from a workflow process, complete the following step.

1. InWorkflow Designer, select the route you want to delete.
2. Press DELETE.

Set a default route for a queue

If more than one outgoing route is available for a queue, you can designate one of the routes as the default
route. To set a default route for a queue, complete the following steps.

1. Double-click the queue.
2. Inthe Queue Properties dialog box, in the left pane, click Routes.

Note: The default route is automatically set in the Route Forward dialog box.

3. Onthe Routes Out tab, in the Route Name list, select the route you want to set as the default for this
queue and then click Make Default.

Note: This functionality is not available for routes to super queues. Therefore, super queue routes do
not appear in the Route Name list.

4. Click OK.
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Restrict access on a route

You can restrict users and groups from having access to a route in a workflow process. To restrict access on
aroute, complete the following steps.

Double-click the queue that uses the route you want to modify.

In the Queue Properties dialog box, click Routes.

On the Routes Out tab, select the route you want to modify from the list, and then click Modify.
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In the Modify Route Out dialog box, if you are a Workflow Manager, restrict users from the queue. On
the Restrictions tab, select any users or groups in the available users and available groups lists that
you want to prevent from using this route, and then click Add.

5. Click OK until you return to the process diagram.

Change route style

To change the style of the route arrows in a workflow process diagram, complete the following step.

o Onthe Grid toolbar, click one of the following route style buttons.
« Orthogonal Routes "+

« Normal Routes |

« Curved Routes L

View all the routes for a queue

From the workflow process diagram, you can view all routes for a queue. To view all routes for a queue,
complete the following steps.

1. Open the process containing the queues and routes you want to view.
2. Click to select the queue for which you want to view all the corresponding routes.
Result The routes will appear in bold, easily apparent compared to all other routes in your process diagram.

Work with reason lists

What is a reason list?

Reason lists provide users the ability to indicate why they are putting a workflow item on hold.

When putting an item on hold in a workflow queue, users are prompted to select a reason from a reason list.
As manager of a workflow process, you control the contents of every On Hold reason list. You can define a
reason list as part of a workflow queue's properties.

Modify or rename a reason list for putting an item on hold

Reason lists are created to provide users with predefined reasons for putting workflow items on hold. To
modify a reason list for putting an item on hold, complete the following steps.

1. Complete one of the following actions, depending on the situation.



Situation Steps

Modify a hold reason list in Management 1. In Management Console, in the left pane,
Console under Select Department, select a
department from the list.

2. Inthe left pane, click Workflow.
Click the Reason Lists tab.

4. Click the list you want to change and then
click Modify.

w

Modify a hold reason list in Workflow Designer | 1. Double-click the queue.

2. Inthe Queue Properties dialog box, click
Reasons in the left pane.

3. Inthe Select a reason list to use when
placing items On Hold in this queue list,
click the list you want to change and then
click Modify.

2. Inthe Reason List dialog box, on the General tab, change the name and description if necessary.

Note: You cannot change the name of a system list (Apply Signature, Void/Expire Digital ID, or Void
Signature).

3. Tomake the reason list inactive, clear the Is active check box.
Note: You cannot disable a system list.

4. Inthe List Members tab, add, remove, or rearrange reasons.
5. Click OK.
Add a reason list for putting an item on hold

When putting an item on hold in a workflow queue, the user must select the reason for the change from a
reason list. To create and edit a reason list, complete the following steps.

1. Complete one of the following actions, depending on the situation.

Situation Steps

Create a hold reason list in Perceptive Content 1. In Management Console, in the left pane,
under Select Department, select a
department from the list.

2. Inthe left pane, click Workflow.




Situation Steps

3. Onthe Reason Lists tab, click New.

Create a hold reason list in Workflow Designer | 1. In Workflow Designer, double-click the
queue.

2. Inthe Queue Properties dialog box, click
Reasons > New.

2. Inthe Reason List dialog box, type a name and optional description for the reason list and then leave
the Is active check box selected.

3. Onthe List Members tab, add, remove, and rearrange reasons as necessary.
4. Click OK.

Work with statistics

What are statistics?

Statistics are calculations such as the maximum, minimum, and average of all the values in a specific column
that appear in the search results for the view.

You can define statistics for any document view, folder view, task view, record view, or record folder view for
which you have management privileges. You cannot define statistics for a public filter or a related view.

For any folder type for which you have management privileges, you can create a view that determines the
appearance of the folder content results in Folder Viewer. You can also create a statistic for a workflow view,
which defines the appearance when viewing the contents of a workflow queue. When you define a set of
statistics for a folder content or workflow view, the statistics appear in a pane below the search results grid. In
the statistics pane, you can view the statistics, highlight the search results in the grid that apply to the
statistic, and, if only one document or folder matches the statistic value, open the document or folder.

The following examples demonstrate some ways you can use view statistics.

Accounts Payable: Theresa is an Accounts Payable administrator who wants to quickly view the total
of all the invoices in her "Openlnvoices" view. This view contains a custom property column which
stores the invoice amount for each document. Because it is a numeric custom property, Theresa adds
a Sum statistic on this custom property column named "Total open amount". Every time she runs a
search using this view, she sees the total invoice amount of all the documents returned by the search
in the statistics pane.

Admissions: Sam is an Admissions director who wants to view the average ACT score of the students
who applied to his university in the current academic year. His student folder view contains a custom
property column which stores the ACT score for each student and a date range that spans the current
academic year. Because the view uses a numeric custom property, Sam adds an Average statistic on
this custom property column named "Average ACT."



Healthcare: Dr. Lovelace wants to quickly view the next task he is responsible for in his folder view
that lists all his patients with document deficiencies. His view administrator adds a Next statistic to
the task due date column in the view. When Dr. Lovelace logs in, he can quickly see the date the next
task is due, highlight the document associated with the task, and open it in ImageNowViewer.

To view records functionality, you must install a Records Manager license.

Data types for statistical functions

The statistical functions you can define depend on the data type of the column values. To add a statistic for a
custom property column, you must first add the custom property column to the view. The following statistics
are available for the specified data types.

Statistical functions

Average
This function calculates the average of the column values.

Column value data type

Numeric

Sample columns
Summary Task Count

<Number custom property>

Count

This function counts the number of values in the search results grid that match the selected variable
(you must select a variable for this statistical function).

Column value data type

String, list, flag

Sample columns
Folder Name
In Workflow
<List custom property>
<String custom property>

<Flag custom property>

Count Future
This function counts the number of the column's date values that occur in the future.
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Column value data type

Date

Sample columns
Next Task Due
Due Date

<Date custom property>

Count Past
This function counts the number of the column's date values that occur in the past.

Column value data type

Date

Sample columns
Created
Last Viewed

<Date custom property>

First

This function distinguishes the earliest date in the column’s search results.
Column value data type

Date

Sample columns
Modified
Checked Out

<Date custom property>

Last

This function distinguishes the latest date in the column’s search results.
Column value data type

Date



Sample columns
Checked In
Assigned

<Date custom property>

Maximum
This function distinguishes the largest numeric value in the column's search results.

Column value data type

Numeric

Sample columns
Pages

<Number custom property>

Median
The function distinguishes the middle value in the column's search results.

Column value data type

Sample columns
Current Version

<Number custom property>

Minimum
This function distinguishes the smallest numeric value in the column's search results.

Column value data type

Numeric

Sample columns
Days Until Due

<Number custom property>

Mode

This function distinguishes the most frequently occurring numeric value in the column's search
results.



Column value data type

Numeric

Sample columns
Summary Task Count

<Number custom property>

Next

This function distinguishes the next sequential date value in the column's search results.
Column value data type

Date

Sample columns
Status Changed

<Date custom property>

Previous
This function distinguishes the previous sequential date value in the column's search results.

Column value data type

Date

Sample columns
Completed

<Date custom property>

Sum
This function calculates the total of the values in the column's search results.

Column value data type

Numeric
Sample columns
Pages

<Number custom property>



Add view statistics overview

The configuration of a view statistic differs based on the data value type you select. You can create statistics
for document, folder, folder content, record, task, and workflow views. To create a statistic for a view,
complete any of the following procedures.

o /.

o /.

o /.

o /.

o /.

Add a statistic for a date value

You can display the newest, oldest, or next date value in a list of search results, or display the total number of
dates in the past or dates in the future. To add a statistic for a date value, complete the following steps.

Prerequisite Before you can add a statistic for a date custom property value, you must first add the custom
property column to the view.

1. Access the view preview using one of the following methods.

Situation Steps

Create a date statistic for a view 1. Open the view in View Designer.
2. InView Designer, click View > Preview.

Create a date statistic for a container content 1. In Management Console, in the left pane,
view select Folder Types.

2. Intheright pane, select the folder type and
click Modify.

3. Inthe Folder Type dialog box, on the
Appearance tab, click the Preview button.

Create a date statistic for a workflow queue view | 1. Open the workflow process in Workflow
Designer.

2. Double-click the queue to open the Queue
Properties window.

3. Inthe Queue Properties window, in the left
pane, select Appearance.

4. Inthe right pane, click Preview.

Create a date statistic for a workflow process 1. Open the workflow process in Workflow
view Designer.




10.

Situation Steps

2. Click File > Properties.

3. Inthe Process Properties dialog box,
under Appearance, click Preview.

In the Preview pane, click the Statistics button.
In the Statistics dialog box, click Add.
Under Label, type a label that describes the statistical function to appear in the search results grid.

Example If adding a statistic to view the next task due date, type Next task due.

Under Column, select the view column with the date values.

Under Function, select one of the following options depending on the display variable you want to
show:

Situation Steps

Total number of dates in the future « Select Count Future.
Total number of dates in the past « Select Count past.
Oldest date value « Select First.

Newest date value « Select Last.

The next future date « Select Next.

The most recent date « Select Previous.

Optional. Under Caption, select the value to display when the statistic only applies to one search
result.

Example If a Previous statistic shows the last viewed item, and you want to quickly display the user
name of the user who viewed the item, you can use the Caption column to select the Last Viewed By
user.

Optional. To reorder the statistic, click the Move Up or Move Down button until the statistic reaches
the desired position.

Click OK.

The statistic appears below the grid in the Preview pane.

In the Preview pane, click the Run button to test the statistic's performance.



Add a statistic for a flag value

You can add a statistic that distinguishes the number of search results that have a true or false (boolean)
value. To add a statistic for a flag value, complete the following steps.

Prerequisite Before you can add a statistic for a flag custom property value, you must add the flag custom
property column to the view.

1. Access the view preview using one of the following methods.

Situation Steps

Create a date statistic for a view 1. Open the view in View Designer.
2. InView Designer, click View > Preview.

Create a date statistic for a container content 1. In Management Console, in the left pane,
view select Folder Types.

2. Inthe right pane, select the folder type and
click Modify.

3. Inthe Folder Type dialog box, on the
Appearance tab, click the Preview button.

Create a date statistic for a workflow queue view | 1. Open the workflow process in Workflow
Designer.

2. Double-click the queue to open the Queue
Properties window.

3. Inthe Queue Properties window, in the left
pane, select Appearance.

4. Inthe right pane, click Preview.

Create a date statistic for a workflow process 1. Open the workflow process in Workflow
view Designer.

2. Click File > Properties.

3. Inthe Process Properties dialog box,
under Appearance, click Preview.

2. Inthe Preview pane, click the Statistics button.

3. Inthe Statistics dialog box, click Add.

4. Under Label, type a label that describes the statistical function to appear in the search results grid.
Example If adding a statistic to count the number of documents or records assigned to a retention
policy, type Documents in RetentionoOrRecords in Retention.

5. Under Column, select the view column with the flag values.

6. Under Function, select Count.



7. Under Variable, select whether you want to count the results that meet the TRUE condition or the
FALSE condition.

8. Optional. Under Caption, select the value to display when the statistic applies to only one search
result.

Example If there is one version-controlled item in your search results, and you want to quickly display
the user who marked the item private, you can use the Caption column to select the Private By user.

9. Optional. To reorder the statistic, click the Move Up or Move Down button until the statistic reaches
the desired position.

10. Click OK.
The statistic appears below the grid in the Preview pane.
11. Inthe Preview pane, click the Run button to test the statistic's performance.

Add a statistic for a list value

You can add a Count statistic that distinguishes a unique value of a list custom property. To add a statistic for
a list value, complete the following steps.

Prerequisite Before you can add a statistic for a list value, you must first add the list custom property
column to the view.

1. Access the view preview using one of the following methods.

Situation Steps

Create a date statistic for a view 1. Open the view in View Designer.
2. InView Designer, click View > Preview.

Create a date statistic for a container content 1. In Management Console, in the left pane,
view select Folder Types.

2. Intheright pane, select the folder type and
click Modify.

3. Inthe Folder Type dialog box, on the
Appearance tab, click the Preview button.

Create a date statistic for a workflow queue view | 1. Open the workflow process in Workflow
Designer.

2. Double-click the queue to open the Queue
Properties window.

3. Inthe Queue Properties window, in the left
pane, select Appearance.

4. Inthe right pane, click Preview.




10.

11.

Situation Steps

Create a date statistic for a workflow process 1. Open the workflow process in Workflow
view Designer.

2. Click File > Properties.

3. Inthe Process Properties dialog box,
under Appearance, click Preview.

In the Preview pane, click the Statistics button.

In the Statistics dialog box, click Add.

Under Label, type a label that describes the statistical function to appear in the search results grid.
Example If you have a list custom property to select the fiscal quarter associated with an invoice and
you want to add a statistic to show fourth quarter invoices, type Invoices in Q4.

Under Column, select the list custom property.

Under Function, select Count.

Note: Countis the only statistical function for list values.

In the Variable list, select an item from the list to use for the statistic.
Optional. Under Caption, select the value to display when the statistic applies to only one search
result.

Example If there is only one item added to workflow during the month of January, and you want to
quickly display the user who added the item to workflow, you can use the Caption column to select the
workflow user.

Optional. To reorder the statistic, click the Move Up or Move Down button until the statistic reaches
the desired position.

Click OK.

The statistic appears below the grid in the Preview pane.

In the Preview pane, click the Run button to test the statistic's performance.

Add a statistic for a numeric value

You can display the average, sum, median, or mode statistic that distinguishes numeric values, such as the
number of tasks or a custom property that stores an amount value. To add a statistic for a numeric value,
perform the following steps.

Prerequisite Before you can add a statistic for a flag custom property value, you must add the flag custom
property column to the view.

1.

Access the view preview using one of the following methods.




Situation Steps

—_

Create a date statistic for a view Open the view in View Designer.

2. InView Designer, click View > Preview.
Create a date statistic for a container content 1. In Management Console, in the left pane,
view select Folder Types.

2. Intheright pane, select the folder type and
click Modify.

3. Inthe Folder Type dialog box, on the
Appearance tab, click the Preview button.

Create a date statistic for a workflow queue view | 1. Open the workflow process in Workflow
Designer.

2. Double-click the queue to open the Queue
Properties window.

3. Inthe Queue Properties window, in the left
pane, select Appearance.

4. Inthe right pane, click Preview.

Create a date statistic for a workflow process 1. Open the workflow process in Workflow
view Designer.

2. Click File > Properties.

In the Process Properties dialog box,
under Appearance, click Preview.

In the Preview pane, click the Statistics button.

In the Statistics dialog box, click Add.

Under Label, type a label that describes the statistical function to appear in the search results grid.
Example If adding a statistic to view the average amount of invoices, type Average invoice
amount.

Under Column, select the view column with the flag values.

Under Function, select the display variable you want to show.

Optional. Under Caption, select the value to display when the statistic applies to only one search
result.

Example If a Maximum statistic displays the invoice with the highest amount, and you want to quickly
display the user name of the user who last viewed the invoice, you can use the Caption column to
select the Last Viewed By user.

Optional. To reorder the statistic, click the Move Up or Move Down button until the statistic reaches
the desired position.



9. Click OK.
The statistic appears below the grid in the Preview pane.
10. Inthe Preview pane, click the Run button to test the statistic's performance.

Add a statistic for a string value

You can add a non-case sensitive Count statistic that distinguishes string values, such as a task template or
drawer name. To add a statistic for a string value, which you can add at the view or filter level, perform the
following steps.

Prerequisite Before you can add a statistic for a flag custom property value, you must add the flag custom
property column to the view.

1. Access the view preview using one of the following methods.

Situation Steps

Create a date statistic for a view 1. Open the view in View Designer.
2. InView Designer, click View > Preview.

Create a date statistic for a container content 1. In Management Console, in the left pane,
view select Folder Types.

2. Intheright pane, select the folder type and
click Modify.

3. Inthe Folder Type dialog box, on the
Appearance tab, click the Preview button.

Create a date statistic for a workflow queue view | 1. Open the workflow process in Workflow
Designer.

2. Double-click the queue to open the Queue
Properties window.

3. Inthe Queue Properties window, in the left
pane, select Appearance.

4. Inthe right pane, click Preview.

Create a date statistic for a workflow process 1. Open the workflow process in Workflow
view Designer.

2. Click File > Properties.

In the Process Properties dialog box,
under Appearance, click Preview.

2. Inthe Preview pane, click the Statistics button.
3. Inthe Statistics dialog box, click Add.
4. Under Label, type alabel that describes the statistical function to appear in the search results grid.



Example If adding a statistic to count the number of items scanned by the department manager, type
Scanned by Manager.

5. Under Column, select the view column with the string values.
6. Under Function, select Count.

Note: Count is the only statistical function for string values.

7. Under Variable, type the value for the statistic, such as the drawer name or task template name.
8. Optional. Under Caption, select the value to display when the statistic applies to only one search
result.

Example If there is only one items for a specific vendor in your workflow process, and you want to
quickly determine if it is an invoice or a purchase order, you can use the Caption column to show the
Document Type.

9. Optional. To reorder the statistic, click the Move Up or Move Down button until the statistic reaches
the desired position.

10. Click OK. The statistic appears below the grid in the Preview pane.
11. Inthe Preview pane, click the Run button to test the statistic's performance.

Modify a statistic

To modify the components of a statistic defined for a view, complete the following steps.

1. Access the view preview using one of the following methods.

Situation Steps

Create a date statistic for a view 1. Open the view in View Designer.
2. InView Designer, click View > Preview.

Create a date statistic for a container content 1. In Management Console, in the left pane,
view select Folder Types.

2. Intheright pane, select the folder type and
click Modify.

3. Inthe Folder Type dialog box, on the
Appearance tab, click the Preview button.

Create a date statistic for a workflow queue view | 1. Open the workflow process in Workflow
Designer.

2. Double-click the queue to open the Queue
Properties window.

3. Inthe Queue Properties window, in the left
pane, select Appearance.




4.
5.

Situation

Steps

4. Inthe right pane, click Preview.

Create a date statistic for a workflow process
view

1. Open the workflow process in Workflow
Designer.

2. Click File > Properties.

3. Inthe Process Properties dialog box,
under Appearance, click Preview.

In the Preview pane, click the Statistics button and then, in the Statistics dialog box, click the row of

the statistic you want to change.
Do one of the following actions.

« Tochange the statistic definition, highlight the statistic row and then modify the components you

want to change.

« Toreposition the statistic, click Move Up to move it ahead of the preceding statistic, or click Move

Down to move it after the following statistic.
Click OK.

In the Preview pane, click the Run button to test the statistic's performance.

Remove a statistic

1.

To remove a statistic from a view, complete the following steps.

Access the view preview using one of the following methods.

Situation

Steps

Create a date statistic for a view

Open the view in View Designer.
2. InView Designer, click View > Preview.

Create a date statistic for a container content
view

1. In Management Console, in the left pane,
select Folder Types.

2. Intheright pane, select the folder type and
click Modify.

3. Inthe Folder Type dialog box, on the
Appearance tab, click the Preview button.

Create a date statistic for a workflow queue view

1. Open the workflow process in Workflow
Designer.

2. Double-click the queue to open the Queue




Situation

Steps

Properties window.

3. Inthe Queue Properties window, in the left
pane, select Appearance.

4. Inthe right pane, click Preview.

Create a date statistic for a workflow process
view

1. Open the workflow process in Workflow
Designer.

2. Click File > Properties.

3. Inthe Process Properties dialog box,
under Appearance, click Preview.

2. Inthe Preview pane, click the Statistics button.

3. Inthe Statistics dialog box, click the row of the statistic you want to remove and click Remove.

4. Click Yes in the confirmation prompt and then, in the Statistics dialog box, click OK.

Result Removing a statistic does not remove the column from the view.

Work with rules and scripts

What are rules and scripts?

Rules and scripts help you manage items as you move them through workflow queues.

In Workflow Designer, rules let you create conditional alarms and routes. Typically, you would use workflow

rules to set up alarms and to route items through your work queues. You can create rules and specify

conditions in order to trigger an event on a queue. There are two types of rules: Routing and Alarm. Once you

have created your rules, you set the order in which you want to apply them, and then you activate them.

Scripts are typically used when you want to automate actions such as to printing, faxing or emailing. You
might also use a script to strip elements from a numeric string, such as slashes from a telephone number or

hyphens from a social security number.

You can define rules and scripts as part of a queue's properties.

Add a rule action to a queue

To add a routing or alarm rule to a workflow queue as a within queue action, complete the following steps.

1. Double-click the queue.

2. Inthe Queue Properties dialog box, in the left pane, do one of the following actions.
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Situation Steps
To add a routing rule to the queue 1. Click Actions.
2. Inthe right pane, on the Within Queue tab,

in the Action list, select the routing rule.

Optional. Set a waiting period that must
elapse before the action is executed by
selecting or typing a number in the Skip
items in queue less than box, and thenin
the list, select the duration type of minutes,
hours, or days.

To add an alarm to the queue

Hp LN~

o

Click Alarms.
In the right pane, click Add.
In the Select Alarm dialog box, click New.

In the Alarm Settings dialog box, type a
name for the rule.

Verify the Status is set to Active.

In the Alarm rule list, select the alarm rule
and click OK.

In the Select Alarms dialog box, select the
alarm and click Add.

Note: The Timeout Period for alarm rules only applies if the client loses communication with Alarm
Agent. Contact Perceptive Software Product Support before changing this setting.

3. Click OK until you return to Workflow Designer.

Rules

Create a conditional route overview

To route items between workflow queues based on a set of conditions, complete the following procedures.
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Create a routing rule

To create a routing rule used to route items between workflow queues, complete the following steps.
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In Workflow Designer, in the Tasks pane, click Actions.
Click Manage Actions.

Inthe Action Settings dialog box, on the Rules tab, click New.
In the Rules Editor, in the Rules name box, type a name.
Click OK until you retun to Workflow Designer.

Add a rule statement

To copy a statement for a workflow routing rule to simplify new statement creation, complete the following

steps.

1. InWorkflow Designer, in the Tasks pane, click Actions.

2. Click Manage Actions.

3. Inthe Action Settings dialog box, on the Rules tab, select the rule you want to modify and then click
Modify.

4. Inthe Rules Editor, under Statements, click New.

5. Inthe Statement Editor, edit the rule name, define conditions, and set statement actions.

6. Click OK until you return to Workflow Designer.

Modify rule statement conditions

To modify the conditions associated with a statement that is part of a workflow routing rule, complete the
following steps.

In Workflow Designer, in the Tasks pane, click Actions.
Click Manage Actions.

In the Action Settings dialog box, on the Rules tab, select the rule you want to modify and then click
Modify.

In the Rules Editor, under Statements, select a statement and click Modify.



5. Inthe Statement Editor, complete any of the following actions.

Situation Steps
Add statement conditions 1. Under Conditions, click the Add= button
and create the conditions you want to use
with this rule.
2. Repeat step for each condition you want to
create.
Change statement conditions 1. Under Conditions, double-click the

condition and modify the condition.

2. Repeat step for each condition you want to
change.

Remove statement conditions 1. Under Conditions, select the condition.

2. Click the Delete?® button.
3. Repeat steps for each condition you want to

delete.
Reorder statement conditions 1. Under Conditions, select the condition.
2. Clickthe Move Up 1 or Move Down
button.
3. Repeat step for each condition you want to
change.
Group or upgroup statement conditions 1. Under Conditions, select the condition or
conditions.

2. CIicktheGroup: :orUngroup::.:button.

3. Repeat step for each condition you want to
change.

Change a statement condition operator « Under Conditions, click the AND or OR
operator.

6. Click OK until you return to Workflow Designer.
Modify a routing rule statement action

To to modify the action for a statement in a workflow routing rule, complete the following steps.

1. InWorkflow Designer, in the Actions pane, click Manage Actions.

2. Inthe Action Settings dialog box, on the Rules tab, select the routing rule you want to modify and click
Modify.



3. Inthe Rules Editor dialog box, under Statements, select the statement and click Modify.
4. Inthe Statement Editor, under Actions, select the action and click Modify.

5. If modifying a routing action, in the Queues dialog box, as necessary, select a workflow process and
add or remove queues.

6. If modifying a Set custom property action, in the Set Custom Property dialog box, as necessary,
select a custom property from the list and then, under Set value to, complete one of the following
options.

« Inthe Supplied value field, type a value or select one from the list.

« Toset the selected property to another property of the same type, select Property and then select
a value from the list.

You cannot set alist or flag custom property to a property of the same type. To set a property to a blank
value, leave the field blank or select the blank value from the list.

7. Click OK to return to the Rules Editor.
8. Inthe Rules Editor, if you have more than one statement, reorder the statements as necessary.

Statement processing stops after any statement evaluates true, so the order of the statements is
important if an item could evaluate true for more than one statement. The statement order determines
the processing priority.

9. Under Status, click Active and then click OK until you return to Workflow Designer.
Activate a rule

To make a routing or alarm rule active, complete the following steps.

1. InWorkflow Designer, in the Tasks pane, click Actions.

2. Click Manage Actions.

3. Inthe Action Settings dialog box, on the Rules tab, select the rule you want to modify and then click
Modify.

4. Inthe Rules Editor, under Status, select Active.

5. Click OK until you return to Workflow Designer.

Create a conditional route

To create an outbound route for a workflow that routes item to specified queues based on a condition,
complete the following steps.

Double-click the queue.

In the Queue Properties window, in the left pane, click Routes.

In the right pane, on the Routes Out tab, click Add.

In the Add Route Out dialog box, on the General tab, in the Name box, type a name for your route.
In the Type list, select Conditional.
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Optional. In the Conditions list, select Edit Rules.... In the Rules dialog box, complete any of the
following substeps.

1. Tocreate anew rule, click New..., and in the Rules Editor dialog box, define the Rule name,
Rule type, and Statements for the rule, and click OK..



2. Tomodify an existing rule, select the rule, and click Modify. In the Rules Editor dialog box, edit
the Rule name, Rule type, and Statements for the rule, and click OK.

3. Toshare the rule with another department, click Share. In the Share <Rule name> dialog box,
check the boxes of the departments you want to share the reason list with, and then click OK.

7. Inthe Condition list, select the conditional routing rule.
8. Click OK until you return to Workflow Designer.

Create a conditional parallel route overview

A conditional parallel routing rule is evaluated when you manually route an item forward. To create an outgoing
conditional parallel route for a workflow queue, complete the following sequence of procedures.

.

.

.

.
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Create a conditional parallel routing rule

To create a routing rule you can define for a conditional parallel route, complete the following steps.

In Workflow Designer, in the Actions pane, click Manage Actions.

In the Action Settings dialog box, on the Rules tab, click New.

In the Rules Editor dialog box, in the Rule name box, type a name.

In the Rule type box, click Routing rule.

Under Statements, click New and complete the following substeps.

1. Inthe Statement Editor, in the Statement name box, type a name.
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2. Under Conditions, click the AdeUE‘ button and create the conditions you want to use with this
rule.

6. Under Actions, complete any of the following steps.

1. To route the workflow items to a queue when the item meets the conditions, click Add > Route
To.

2. Toset acustom property value when the item meets conditions, click Add > Set custom
property.
If routing to a queue, in the Queues dialog box, select a workflow process and queue and click Add.

8. If setting a custom property value, in the Set Custom Property dialog box, select a custom property
from the list and then, under Set value to, complete one of the following options.

« Inthe Supplied value field, type a value or select one from the list.

« Toset the selected property to another property of the same type, select Property and then select

a value from the list.
You cannot set a list or flag custom property to a property of the same type. To set a property to a blank
value, leave the field blank or select the blank value from the list.

9. Click OK to return to the Rules Editor.



10.

11.

In the Rules Editor, if you have more than one statement, reorder the statements as necessary.

Statement processing stops after any statement evaluates true, so the order of the statements is
important if an item could evaluate true for more than one statement. The statement order determines
the processing priority.

Under Status, click Active and then click OK until you return to Workflow Designer.

Create a conditional parallel route

To create an outbound route that conditionally routes a workflow item in parallel to another queue, complete
the following steps.

A ODN -

hd

8.

Double-click the queue for which you want to create the outbound route.

In the Queue Properties dialog box, in the left pane, click Routes.

In the right pane, on the Routes Out tab, click Add.

In the Add Route Out dialog box, on the General tab, in the Name box, type a name.

1. Inthe Condition list, select the conditional parallel route you created in the previous procedure
and click OK.

In the Type list, select Conditional Parallel.

Optional. In the Conditions list, select Edit Rules.... In the Rules dialog box, complete any of the
following substeps.

1. Tocreate anew rule, click New..., and in the Rules Editor dialog box, define the Rule name,
Rule type, and Statements for the rule, and click OK..

2. Tomodify an existing rule, select the rule, and click Modify. In the Rules Editor dialog box, edit
the Rule name, Rule type, and Statements for the rule, and click OK.

3. Toshare the rule with another department, click Share. In the Share <Rule name> dialog box,
check the boxes of the departments you want to share the reason list with, and then click OK.

In the Condition list, select the conditional routing rule.
In the Queue Properties dialog box, click OK.

Test conditional parallel routing

To determine whether items are evaluated and routed in correctly in a conditional parallel process, complete
the following steps.

1.
2.
3.

Add an item to the first queue in your parallel workflow process.
Route the workflow item through the conditional route.

Ensure that the workflow item siblings end up in the correct queues according to whether the workflow
item met the conditional rule.

In the parallel queues, verify that each parallel queue has a sibling of the workflow item that is supposed
to have a sibling.

In the parallel queues, route each sibling to the Join queue in the process.

In the queue you designated as the Join queue, verify that the workflow siblings have joined together. If
Jauiseemg for siblings
, then at least one sibling still needs to be routed to the Join queue.
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Create an out of office event rule overview

To create a routing or alarm rule for use with an out of office event in workflow, complete the following
procedures.
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Verify the queue user has an active out of office event configured in Management Console.
/1or/1.

.

.

Optional. /1.

1.

1.

.

1.

.

Create an out of office rule statement condition

To create a condition for a statement associated with an out of office alarm or routing rule in workflow,
complete the following steps.

In Workflow Designer, in the Tasks pane, click Actions.
Click Manage Actions.

In the Action Settings dialog box, on the Rules tab, select the rule you want to modify and then click
Modify.

In the Rules Editor, under Statements, complete one of the following options.
« Toadd the out of office condition to an existing statement, select the statement and click Modify.
« Toadd the out of office condition to a new statement, click New.

In the Statement Editor, under Conditions, click the Add button and then, in the Add Condition
dialog box, complete the following substeps.

1. Inthe Constrain by list, select Status.

In the Field list, select Queue is unattended.
In the Operator list, select is equal to.

In the Value list, select Yes.

. Click OK.

Click OK until you retumn to Workflow Designer.
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Modify a rule overview

From the Rules Editor, you can create statements, change the order of statements, change the attributes of a
statement, remove statements, or disable rules. To modify a rule, complete any of the following procedures.

o /.

o /1.

o /.

o /.

A

o /.

Routing and alarm rule conditions

The following tables contain the condition and action options for routing and alarm rules in Workflow Designer.
Applied as inbound, within queue, or outbound actions, rule conditions are evaluated as you route items into,
within, or out of workflow queues. A rule can contain multiple conditions and actions. To activate arule, you
must configure at least one condition and one action.

Note Message Center, Icon, and Audible alarms are not activated for owners, managers, or users with the
Department Privileges > Manage > Workflow Processes privilege.

Conditions

To automatically route a workflow item or to trigger an alarm, you must define a condition. The following table
lists conditions, explains whether the condition is available for routing or alarm rules, lists configuration
criteria, and gives an example of how to use the condition. By default, the condition under the Required for
Alarm Rules column must be configured with the alarm condition.

If you delete an element used in a rule condition, such as a document type or a workflow queue, Workflow
Designer automatically disables the rule. In the Statement Editor for the routing or alarm rule, the disabled
condition appears as (invalid condition).

Content property

A property value associated with a workflow item, such as a document key or type.
Type
Routing rule

Alarm rule



Criteria
Select Drawer, Field1, Field2, Field3, Field4, Field5, Document type, Name, or Type

To use a custom property as a routing condition, define a custom property that is directly assigned to the
document or folder type and that is not part of a composite custom property. If you define a composite
property as a routing condition, that condition is evaluated as FALSE and the items are not routed.

Example

IF Drawer is equal to Default

Custom property
A custom property value associated with a workflow item.

Type
Routing rule

Alarm rule

Criteria

is equal to, is not equal to, is less than, is greater than, is less than or equal to, is greater than or equal to

Example

IF Amount is equal to 100

Status

A status associated with the workflow item.
Type
Routing rule

Alarm rule

Criteria

Select Has required documents, Folder status, Digital signature status, Summary task status, Item
priority, or Queue is unattended

Example

IF Priority is equal to Low

Task property

A property of a task associated with the workflow item.



Type
Routing rule

Alarm rule

Criteria

Select Task due date, Task status, Summary task due date, or Summary task status

Example

IF Task state is equal to any task with state Assigned

User
A user who performs an action on the workflow item.

Type
Routing rule

Alarm rule

Criteria

Select Created by, Digital signature user, or Routing user

Example

IF Creation user is equal to LWalker

Workflow item property

A property of the item in the workflow process or queue.
Type
Routing rule

Alarm rule

Criteria

Queue item count, Creation time, Time in queue, or Routed from queue

Example

IF Time in queue is equal to 2 Days



Actions

To complete a rule statement, you must select an action. You can use the routing actions to specify the queue
where an item is routed and to set a custom property value for that item. With alarm rules, you choose the
type of alarms you want users to receive. The following table lists actions, explains whether the condition is
available for routing or alarm rules, lists configuration criteria, and gives an example of how to use the
condition.

Route to <specified queue>

Route to a specific queue if rule conditions are met, such as IF the queue contains at least
<X> workflow items.

Type
Routing rule
Criteria

Select any queue from an existing process.

Example

THEN Route to Insurance: Approved

Set custom property

Set a custom property value if rule conditions are met, such as IF the queue contains at
least <X> workflow items.

Type
Routing rule
Criteria

Select a date, number, string, flag, list, or user custom property

Example

ALWAYS Set custom property Invoice Status to 'Paid'

Send <email>

Send an email if rule conditions are met, such as IF the queue contains at least <X>
workflow items.

Type

Alarm rule



Criteria

Enter alarm name, e-mail header information, e-mail message, and select e-mail interval.

Example

THEN E-mail Heads up!

<Message Center>

Display a message in the Message Center if rule conditions are met, such as IF the queue
contains at least <X> workflow items.

Type
Alarm rule
Criteria

Enter alarm name, message title, and message body.

Example

THEN Notify Time's up

Flash <icon>

Flash the ImageNow icon if rule conditions are met, such as IF the queue contains at least
<X> workflow items.

Type
Alarm rule
Criteria

Enter alarm name, choose alarm color, and alarm frequency.

Example

THEN Flash icon Ready for Review

Play <sound>

Play an audible alarm when rule conditions are met, such as IF the queue contains at least
<X> workflow items.

Type
Alarm rule

Criteria

Enter alarm name, choose a WAV file, and play interval.



Example

THEN Play sound Limit Exceeded

Remove a rule

To remove a rule from a workflow process, complete the following steps.
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From the Workflow DesignerTask pane, click Actions.

In the Task pane, click Manage Actions.

In the Rules dialog box, select the rule you want to remove, and then click Remove.
When prompted to verify that you want to remove this rule, click Yes.

Click OK and return to Workflow Designer.

Reorder rule statements

To modify a workflow routing rule by reordering the statements in the rule, complete the following steps.

1. InWorkflow Designer, in the Tasks pane, click Actions.

2. Click Manage Actions.

3. Inthe Action Settings dialog box, on the Rules tab, select the rule you want to modify and then click
Modify.

4. Inthe Rules Editor, under Statements, select a statement.

5. Click Move Up or Move Down as necessary.

6. Click OK until you return to Workflow Designer.

Scripts

Add a script to a process

To add a script to a workflow process, complete the following steps.
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From the Workflow Designer task pane, click Actions.
In the task pane, click Manage Actions.

In the Action Settings dialog box, click the iScripts tab.
On the iScripts tab, click Add.

On the Select iScripts dialog box, select the server script you want to add, and then click OK until you
return to Workflow Designer.

Result You do not need to restart Workflow Agent or any other server agents after you add an iScript in
Workflow Designer.

Remove a script

To remove a script from a queue, complete the following steps.

1.

Double-click the queue from which you want to remove a script.



In the Queue Properties dialog box, click Actions.
In the Action list containing the script you want to remove, click Edit Actions.
In the Action Settings dialog box, on the iScripts tab, select a script, and then click Remove.
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Click OK until you retum to Workflow Designer.

Run a script upon opening a workflow item

You can create a VBScript that executes each time a workflow item is open. This is a global script that
executes for all workflow queues in all workflow processes that exist on the ImageNow Server you are
running. To run a script upon opening a workflow item, complete the following steps.

1. Open a workflow item.

2. InlmageNowViewer, click Workflow > Page Load Script.

3. Inthe Workflow Page Load Script dialog box, type in your VBScript, and then click OK.

4. Close the item, and then in the confirmation box, click Yes.
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