Java-Based Applications - Application Enabler - Foundation 23.1 - Foundation 23.1 - Ready - OnBase - Essential - Premier - Standard - external - Premier - Essential - Standard

Application Enabler

Platform
OnBase
Product
Application Enabler
Release
Foundation 23.1
License
Premier
Essential
Standard

In order to enable Java-based applications, Java Access Bridge and Java Virtual Machine must be installed. These two must be compatible with each other. Consult Oracle's compatibility documentation for more information.

The following versions of Java Access Bridge are supported:

Java Access Bridge Version

Important Notes

1.0.2

 

1.2

 

2.0.1

Java Access Bridge 2.0.1 is recommended for any client machines (32-bit only) on which the Java application is running under Java Runtime Engine 1.5 or earlier. The compatibility for Java Access Bridge 2.0.1 is available at: http://www.oracle.com/technetwork/java/javase/documentation/compatibility-137109.html

2.0.2

Java Access Bridge 2.0.2 is required on any 64-bit client machines. It only supports Java Runtime Engine 1.5, 1.6, and 1.7.

2.0.3

Java Access Bridge 2.0.3 is included with Java Runtime Engine 1.7u6 (JRE 7u6) and later. By default, Java Access Bridge is not enabled. To enable Java Access Bridge in this situation, refer to Oracle's instructions available at:

http://docs.oracle.com/javase/7/docs/technotes/guides/access/enable_and_test.html

2.0.4

Java Access Bridge 2.0.4 is included with Java Runtime Engine 1.8u11 (JRE 8u11) and later. By default, Java Access Bridge is not enabled. To enable Java Access Bridge in this situation, refer to Oracle's instructions available at: http://docs.oracle.com/javase/8/docs/technotes/guides/access/enable_and_test.html

The following Java Virtual Machine versions are supported: JDK 1.1.8 and higher.